Bug #62000 failure to execute sql script in connected server
Submitted: 27 Jul 2011 9:29 Modified: 4 Aug 2011 14:31
Reporter: ani hato Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.34 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: MySQL Workbench

[27 Jul 2011 9:29] ani hato
Description:
how to add data to your database, and also how to execute SQL statements
using MySQL Workbench

Exception = System.Runtime.InteropServices.SEHException
Message = External component has thrown an exception.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): External component has thrown an exception.
   at Db_sql_editor.exec_sql(Db_sql_editor* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , shared_ptr<Sql_editor>* , Boolean , Boolean , Boolean )
   at MySQL.GUI.Workbench.Db_sql_editor.exec_sql(String sql, Boolean active_editor, Boolean wrap_with_non_std_delimiter)
   at MySQL.GUI.Workbench.DbSqlEditor.DoExecuteSqlScript(Boolean currentStatementOnly)
   at MySQL.GUI.Workbench.DbSqlEditor.ExecuteSqlScript()
   at MySQL.Grt.RunWrappedDelegate0<void\,void\,MySQL::Grt::DelegateSlot0<void\,void>::ManagedDelegate>.native_callback()
   at sigc.pointer_functor0<void>.()(pointer_functor0<void>* )
   at sigc.adaptor_functor<sigc::pointer_functor0<void> >.()(adaptor_functor<sigc::pointer_functor0<void> >* )
   at sigc.internal.slot_call0<sigc::pointer_functor0<void>,void>.call_it(slot_rep* rep)
   at mforms.ToolBarItem.callback(ToolBarItem* )
   at MySQL.Forms.ToolBarItemImpl.OnItemActivation(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripButton.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
when you click on execute sql script in connected server
[27 Jul 2011 10:26] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=61999 marked as duplicate of this one.
[30 Jul 2011 18:47] Valeriy Kravchuk
What exact server version, x.y.z, local or remote, do you use?
[4 Aug 2011 14:31] Alfredo Kojima
duplicate of bug #60750