Bug #61995 MySQL Workbench randomly crashes when stablishing a Connection
Submitted: 27 Jul 2011 5:07 Modified: 5 Sep 2011 22:28
Reporter: Sergio Bobillier Email Updates:
Status: Verified Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.34 rev 7780 OS:Linux (Ubuntu 11.04)
Assigned to: CPU Architecture:Any
Tags: connecting, crash, segmentation fault, workbench

[27 Jul 2011 5:07] Sergio Bobillier
Lately MySQL Workbench have been crashing a lot when connecting to the server. After double clicking an existing connection, regardless of the connection type (Standard TCP/IP or Standard TCP/IP over SSH) the Workbench crashes before showing the Password dialog or after inserting the password.

It crashes with a Segmentation Fault error. The behavior is totally random. It can crash in any of the two points indicated in the "How to repeat" section or not crash at all.

I have tried it connecting to:

MySQL Server 5.1.54-1ubuntu4 running on Ubuntu 11.04
MySQL Server 5.1.41-3ubuntu12.10 running on Ubuntu 10.04

I tried to delete the config directory under my home: ~/.mysql/workbench and It did not fix the problem, then I tried to totally remove (purge) MySQL Workbench and reinstalling it and still crashes.

Is the same on my desktop and laptop computers.

I don't know if this bug can be fixed since it is so random. Maybe it only happens to me. I wasn't going to report it but it annoyed me enough already! I'm tired of starting the workbench over an over again to achieve a connection.

How to repeat:
Start MySQL Workbench, create a connection (It can be a Standard TCP/IP or a Standard TCP/IP over SSH Connection) then double click the connection to connect to the server. Also you can simply click the "Open a Connection to Start Querying" button and insert the connection details.

-- MySQL Workbench sometimes crashes here --

If it doesn't crash it will show the password dialog (if the password is not saved). Put in your password and click Ok.

-- MySQL Workbench sometimes crashes here --
[25 Aug 2011 15:56] Valeriy Kravchuk
Please, start Workbench from shell and send output from it until crash.
[26 Aug 2011 6:56] Roberto Larcher
mysql.workbench output before and after crash

Attachment: output.txt (text/plain), 60.94 KiB.

[26 Aug 2011 7:03] Roberto Larcher
The file I attached in the previous post is the mysql-workbench output in the case of crash 1 (referring to the numeration introduced by Sergio Bobillier)
[26 Aug 2011 12:51] Armando Lopez Valencia
Thanks a lot for your report.
Defect Logged in DB.
[26 Aug 2011 17:12] Sergio Bobillier
Well I didn't think anyone else was going to submit information on this bug it is a relief that I'm not the only one having this trouble.

Here's an important update. This bug also happens when connection to server version: 5.0.83-community-log (I don't know what O/S it that server running on).

The crash also happens when I let the workbench inactive for a while. When I come back it asks me for the password again (because the server disconnected it for inactivity) and when I enter the password the Workbench crashes. This may be just another case of the first type of crash I reported.

I just can't reproduce the bug just now. I will attach the output when it happen again.
[5 Sep 2011 22:28] Sergio Bobillier
I'm attaching the output for the second scenario I described, that is. I double click a connection, workbench asks for the password, I input the password and click OK, then the workbench crashes.
[5 Sep 2011 22:29] Sergio Bobillier
Output for the second scenario

Attachment: output.txt (text/plain), 62.60 KiB.

[19 Oct 2011 7:28] Roberto Larcher
It seems that the bug has been solved in MySQL Workbench 5.2.35.
[2 Oct 2012 21:09] Jose Manuel Gonzalez
Mysql Wrokbench also crash when you are editing a store procedure and you delete some letters/spaces or when you backspace. All the stored procedure code is lost, but no the script in the query maker.
[13 Dec 2012 8:54] Marcin Szalowicz
I think, this bug is similar to this one: http://bugs.mysql.com/bug.php?id=67383