Bug #61959 MYSql Wont Start
Submitted: 22 Jul 2011 22:53 Modified: 23 Jul 2011 3:58
Reporter: Matt Adams Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.1 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[22 Jul 2011 22:53] Matt Adams
Description:
Im running a Mysql Server on a laptop to store Large amounts of Data combined from many projects I run, I keep the Data files stored on an external HDD which is required to be hooked up in order for the MySql Server to run, I was running a Large Import script over night importing many records into my Local HDD when there was a Power outage that Caused the HDD to go offline and not come back on until I manually turned it back on.  When I brought it back online and tried to start the MySql Server I got this error, Iam a very novice user of MySql so Im at a total loss as what to do.

110722 17:30:16 [Note] Plugin 'FEDERATED' is disabled.
110722 17:30:16 InnoDB: The InnoDB memory heap is disabled
110722 17:30:16 InnoDB: Mutexes and rw_locks use Windows interlocked functions
110722 17:30:16 InnoDB: Compressed tables use zlib 1.2.3
110722 17:30:16 InnoDB: Initializing buffer pool, size = 107.0M
110722 17:30:16 InnoDB: Completed initialization of buffer pool
110722 17:30:16 InnoDB: highest supported file format is Barracuda.
InnoDB: Log scan progressed past the checkpoint lsn 79112515861
110722 17:30:16  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 79117758464
InnoDB: Doing recovery: scanned up to log sequence number 79123001344
InnoDB: Doing recovery: scanned up to log sequence number 79126224518
InnoDB: 9 transaction(s) which must be rolled back or cleaned up
InnoDB: in total 9 row operations to undo
InnoDB: Trx id counter is 19B2D00
110722 17:30:19  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 0 1 2 3 4 5 6 7 110722 17:30:25  InnoDB: Error: page 564184 log sequence number 79126332379
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
8 9 110722 17:30:26  InnoDB: Error: page 564216 log sequence number 79126275705
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
110722 17:30:26  InnoDB: Error: page 564222 log sequence number 79126338228
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
10 11 12 13 14 15 16 17 18 19 20 110722 17:30:32  InnoDB: Error: page 1491150 log sequence number 79126275810
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
21 22 23 24 25 26 110722 17:30:35  InnoDB: Error: page 83560 log sequence number 79126261312
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
27 110722 17:30:35  InnoDB: Error: page 83571 log sequence number 79126225689
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
110722 17:30:35  InnoDB: Error: page 83576 log sequence number 79126344820
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
110722 17:30:35  InnoDB: Error: page 83578 log sequence number 79126274679
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
28 29 110722 17:30:37  InnoDB: Error: page 83538 log sequence number 79126261383
InnoDB: is in the future! Current system log sequence number 79126224518.
InnoDB: Your database may be corrupt or you may have copied the InnoDB
InnoDB: tablespace but not the InnoDB log files. See
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: for more information.
30 31 32 33 34 35 36 37 38 39 40 41 42 43 110722 17:30:45  InnoDB: Assertion failure in thread 3332 in file log0recv.c line 1082
InnoDB: Failing assertion: !page || (ibool)!!page_is_comp(page) == dict_table_is_comp(index->table)
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
110722 17:30:45 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=57671680
read_buffer_size=65536
max_used_connections=0
max_threads=100
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 89344 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
InnoDB: Thread 1256 stopped in file os0sync.c line 781
000000013FFD535E    mysqld.exe!my_osmaperr()
000000013FFD6306    mysqld.exe!my_osmaperr()
00000001400049C3    mysqld.exe!my_osmaperr()
000000013FFE979C    mysqld.exe!my_osmaperr()
000000013FFD22FC    mysqld.exe!my_osmaperr()
000000007722652D    kernel32.dll!BaseThreadInitThunk()
00000000775AC521    ntdll.dll!RtlUserThreadStart()
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
InnoDB: Thread 8780 stopped in file os0sync.c line 781

How to repeat:
Power Outage on External HDD (where /data is located) while running Large INSERT INTO * commands from a .sql file
[23 Jul 2011 3:58] MySQL Verification Team
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.
--------
Note:   You should make a physical backup of all the mysql datadir files immediately, to another safe location on another physical disk.   
Then, take a look at this page:
http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recovery.html

Apart from that, there's nothing we can do in bugs.mysql.com as this probably isn't a bug.