Bug #61897 Upgrading reports, "Need Visual C++ 2010", but can't find
Submitted: 18 Jul 2011 14:54 Modified: 17 Nov 2011 16:24
Reporter: Jesse Castleberry Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.34 OS:Microsoft Windows (Server 2003, Win 7 64-bit)
Assigned to: Santo Leto CPU Architecture:Any

[18 Jul 2011 14:54] Jesse Castleberry
Description:
I went to upgrade an old version of WB on one of our servers today and when I try to run the 5.2.34 installation, it immediately comes up with a message stating, "MySQL Workbench requires the Visual C++ 2010 Redistributable Package to be installed. Click the Download-Button on the next page to open a web page containing further instructions."  When I click OK, it brings me back to the installation form with only the Finished button highlighted.  There is no Download button, and I can't seem to find the package being referred to anywhere.

How to repeat:
Try to install the latest on a server w/o the referred to package.

Suggested fix:
Make it actually display a download button, or make it obvious somehow where to download the referred to package.
[18 Jul 2011 15:26] Valeriy Kravchuk
You can download it from http://www.microsoft.com/download/en/details.aspx?id=5555.

I had installed version 5.2.34.2 on 32-bit Windows XP recently, and I remember that it was not needed to search for this, I've just clicked somewhere probably...
[18 Jul 2011 15:46] Jesse Castleberry
Yes, shortly after posting this bug report, I found the link I needed after searching the web.  I guess the point of posting a bug report, though is that the message says, "click the Download button after clicking OK" (or whatever the message was) and there was no Download button, and it didn't give a link where I could download it either.  I have everything installed now, but some additional information may need to be added to that message to make it clearer where to get the library for anyone else who runs into that message.
[19 Jul 2011 12:53] Santo Leto
Thank you for a bug report, verified as described.
	
There should be a "download" button (the first button from the left) but it is not visible (see attached image).

When instead the Install Wizard shows the alert "MySQL Workbench requires the .NET Framework 4..." and you click "Ok", the button to download the NET framework is visible.
[19 Jul 2011 13:00] Santo Leto
61897: images

Attachment: 61897-images.zip (text/html), 251.75 KiB.

[19 Jul 2011 14:51] Peter Laursen
@Santo .. you attachment is a mess!

1) What is the idea of compressing files that already use a compressed formats?
2) The files inside the archive are PNG files with a .jpg extension.
[17 Nov 2011 16:24] Philip Olson
Fixed as of 5.2.36:

+        A <literal>Download Prerequisites</literal> link is now
+        displayed when prerequisites, such as the "Visual C++ 2010
+        Redistributable Package" requirement, are not met. Before, the
+        link was not visible.
[3 Feb 2012 19:07] David Lash
I have a similar problem but already have the Visual C++ 2010 Redistributable Package installed. I've removed and re-installed the Visual C++, re-booted, and even installed Microsoft's free C++ dev package, all to no avail.

Any idea on how to get the mysql workbench installation to recognize the Visual c++ or bypass the check?
[20 Mar 2012 16:05] jamill usmani
Hi 

I am trying to install mysql workbench 5.2.34 on my windows 7 x64 - each time I run the installation - it keeps on asking for the Visual C++ 2010 redistributable package.  I have installed packages for both the x86 and x64 but alas with no luck.

Help.

Jamill.