Bug #61801 Mysql - Visual Studio 2008 - infinite loop
Submitted: 8 Jul 2011 11:51 Modified: 11 Jul 2011 21:43
Reporter: Luca Tonini Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.3.7 OS:Microsoft Windows
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: dataset, infinite loop, TableAdapter, visual studio crash

[8 Jul 2011 11:51] Luca Tonini
Description:
I using Mysql 5.5.18 and connector/net 6.3.7 and Visual studio 2008 sp1
When I edit a TableAdapter with the drawing tool of visual studio 2008 and confirm the changes, visual studio enters an infinite loop which does not end if not killing him.
With MySQL Workbench you can see that the same queries are always made on the structure of the table that references the table adapter changed.
Help me

How to repeat:
1 Make a table in mysql.
2 Make a new project of visual studio 2008 and insert a file of type dataset.
3 With the tool of visual studio on dataset insert a table adapter that link to the table.
4 Edit the table structure on mysql.
5 Edit the table adapter on visual studio editor.
Repeat a few times to point 4 and 5 and the error occurs
[11 Jul 2011 11:40] Bogdan Degtyariov
Hi Luca,

I tried your method of repeating the problem and still no sign of issue in Visual Studio 2008.

Perhaps I got it wrong. Please check what I did on steps 4 and 5.

4. On the server I "run ALTER TABLE `test`.`tab1` ADD COLUMN `ccc` VARCHAR(45) NOT NULL;

5. In Visual Studio I open DataSet designer, right-mouse click on the table and select Add -> Column. Name the column in the same way as it was done on the server. In the column properties I set DataType ->System.String. MaxLength -> 45.

Then I drop the column in MySQL Server table and DataSet table and repeat 4 and 5 again.

Thanks.
[11 Jul 2011 21:43] Luca Tonini
My issue is generate not when i add a column to table adapter but when i edit the fill method of tableadapter to read the new structure.
I change the schema of the table on mysql then i click with right mouse on table adapter in visual studio and i click over "configure".
The query is "select * from tablename". At this moment when i click on "End" to the wizard, start the loop.