Bug #61793 I get a error when a try to generate a model
Submitted: 7 Jul 2011 22:22 Modified: 1 Aug 2011 18:58
Reporter: Leandro Lustosa Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.3.7.0 OS:Microsoft Windows (Win 7 64bits)
Assigned to: Julio Casal CPU Architecture:Any
Tags: 6.3.7.0, 6.4.3.0, connector, information_schema, model, Parameters, table

[7 Jul 2011 22:22] Leandro Lustosa
Description:
I get a error when I generate the model, like this:

An error occurred while executing the command definition. See the inner exception for details.
Unknown table 'PARAMETERS' in information_schema

My configuratiions:
VS2010
Connector 6.3.7.0 or Connector 6.4.3.0
MySql Server 5.1x
Win 7 64bits

If I use the MySql Server 5.5 with the configurations above works fine.

I read the documentation of connectors and see that version 6.3.7.0 works with MySql Server 5.1, so whats get wrong?

How to repeat:
I have a project target for framework 4.0, click with right button

Add --> New item

I choose ADO.NET Entity Data Model

Put the Name Model1.edmx

Generate from Database

New Connection...

Change...

I choose MySql Database

Put the configuration for access localhost database MySql Server 5.1.58, test configurations

Yes, include sensitive data in the connection string

Next

Select All Tables and leave marked Include foreign key collumns in model

And Finish

So I get the error Error:

An error occurred while executing the command definition. See the inner exception for details.
	Unknown table 'parameters' in information_schema

Suggested fix:
With MySql Server 5.5 works fine, I think that the connector 6.3.7 or 6.4.3 don't recognize what server is running.
[11 Jul 2011 10:05] Bogdan Degtyariov
Hi Leandro,

Connector/NET is trying to read the stored procedure parameters from `parameters` table in Information_Schema database. This table exists in MySQL 5.5 or newer.

The driver should check the server version and take the appropriate actions. However, procedure parameter mapping will be unavailable since there is no other way to quickly get the parameter metadata.
[11 Jul 2011 14:20] Leandro Lustosa
So, the only way to use the new connector/NET to Framework .NET 4 or Visual Studio 2010 is migrating the MySql Server to newest version? Don't have another way to use Visual Studio 2010, that's works with MySql Server 5.1x?

Thank you.
[1 Aug 2011 18:59] Julio Casal
Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

The provided steps for reproduction do not trigger the specified error. If you can provide an specific small database schema that would trigger the error that would help to figure out what is wrong.

Thank you for your interest in MySQL.