Bug #61762 Backup crashes through SSH tunnel
Submitted: 5 Jul 2011 22:37 Modified: 25 Oct 2012 13:56
Reporter: Marc Schipperheyn Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.33 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[5 Jul 2011 22:37] Marc Schipperheyn
Description:
When I run a backup through an SSH tunnel, after a while (say a few minutes) Workbench crashes. 
The server is mysql 5.1.49 innodb running on Ubuntu.

06 Dumping mercadototal_prod

Running: "mysqldump.exe" --defaults-extra-file="c:\users\marc\appdata\local\temp\tmphpobpb.cnf"  --no-create-info=FALSE --order-by-primary=FALSE --protocol=tcp --no-data=FALSE --tz-utc=TRUE --flush-privileges=FALSE --compress=FALSE --replace=FALSE --host=localhost --insert-ignore=FALSE --extended-insert=TRUE --user=root --hex-blob=FALSE --quote-names=TRUE --force=FALSE --complete-insert=FALSE --add-locks=TRUE --port=15920 --disable-keys=TRUE --delayed-insert=FALSE --create-options=TRUE --delete-master-logs=FALSE --comments=TRUE --default-character-set=utf8 --max_allowed_packet=1G --flush-logs=FALSE --dump-date=TRUE --lock-tables=TRUE --allow-keywords=FALSE --events=FALSE --databases "mydb"

BTW, I'm not using 5.2.34 because I couldn't use SSH tunneling on it.

How to repeat:
Set up an ubuntu mysql server on Rackspace
Connect to it through Workbench 5.2.33 through an SSH tunnel
Start a mysql export to a self contained file 
Wait for the crash
[5 Jul 2011 22:52] Miguel Solorzano
Could you please try version 5.2.34 and comment your results. Thanks in advance.
[5 Jul 2011 23:02] Marc Schipperheyn
As I stated before SSH tunneling doesn't work at all in 5.2.34. So I can't.
[6 Jul 2011 0:40] Miguel Solorzano
Sorry I didn't noticed about the issue you have with ssh because I am able to create the connection with ssh tunnel for an Ubuntu running on VirtualBox and I am not able to repeat with 5.2.34, anyway please try to repeat the issue and when the message dialog appears right clear around the bug icon and copy to the clipboard the back trace. Paste the back trace here. Thanks.
[6 Jul 2011 13:21] Marc Schipperheyn
Hi, unfortunately ther's no bug popup. It simply crashes and exits
[7 Jul 2011 14:57] Alfredo Kojima
Can you run it from a terminal and when it crashes, save the output and attach to this bug report?
[7 Aug 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[10 Aug 2011 13:50] Marc Schipperheyn
I have found that when the backup crashes, it has partly backed up the data. So this means that the backup does start, but halfway workbench just crashes. It almost seems like Windows 7 is erronously detecting a "not functioning" programming and this starts a cascade leading to a crash.

It could also be some internal timeout that is triggered.
[18 Aug 2011 14:21] Alfredo Kojima
How big is the backup? How long does the backup take?
[18 Aug 2011 15:57] Marc Schipperheyn
Very small around a meg. Sometimes it doesn't save anything and sometimes I get halfway.
[18 Aug 2011 15:58] Marc Schipperheyn
It never completes, but it can take a minute or so until the crash occurs
[23 Aug 2011 14:56] Juan Rene Ramirez Monarrez
Hi Marc

I've been able to reproduce the problem on both 5.2.33 and 5.2.34

The followed procedure was:
1.-Create an ssh connection WITHOUT storing the ssh and mysql passwords
2.-Go to Manage Import/Export and enter the requested passwords...
3.-Selected a database
4.-Export the database to a self contained file

Thanks for submitting the bug, we will work on a solution.
[23 Aug 2011 16:18] Marc Schipperheyn
That's great! I hope this this also leads to a solution for not being able to connect SSL at all in 5.2.34!
[23 Aug 2011 17:49] Juan Rene Ramirez Monarrez
Hey Marc

There's a test I would like you to execute: I'm only being able to reproduce the issue as described, whenever I store the ssh and mysql password in the valut ( using the checkboxes in the password prompts ) WB doesn't crash anymore but it displays an error message on the log.

Could you give it a try storing the password and describe what happens?

Thanks!
[23 Aug 2011 18:31] Marc Schipperheyn
Ok, this is what I tried:
1. Created a new connection with ssl settings but immediately storing passwords in the valut
2. created a server administration instance with ssh login management specified
3. on connection, error: PasswordRequiredException: Private Key is encrypted
4. changed connection to do not use remote management
5. login ok
6. export database, set Check dump stored routines, export to self contained file
7. crash
8. try again
9. crash
[25 Oct 2012 13:56] Armando Lopez Valencia
Fixed in previous releases.