Bug #61755 MySQL Server Installation over existing server data files
Submitted: 5 Jul 2011 15:44 Modified: 12 May 2016 17:59
Reporter: Armando Lopez Valencia Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:5.5.13.3 OS:Microsoft Windows (Windows 7x86)
Assigned to: Assigned Account CPU Architecture:Any

[5 Jul 2011 15:44] Armando Lopez Valencia
Description:
MySQL Server Password Problem

How to repeat:
1. Install a MySQL Server.
2. Create a DB in the installed MySQL Server.
3. Take note of the password used IE: "test"
4. Uninstall the MySQL Server without deleting the previously created server files (DB).
5. Install a MySQL Server.
6. Click "Next >" until you get to the "MySQL Server Configuration" page.
7. Enter a wrong "Current Root Password" IE: "xxxx".
8. Use a new and different password IE: "bug".
9. Complete the installation.
10. Open Workbench
11. Make a new connection.

Actual Results:
The password used ("bug") do not work, if you are using windows 7x64 the password will be "" if you are using windows 7x86 the password will be the old password ("test").

Expected results: 
The New password should work ("bug").
[5 Jul 2011 16:26] Johannes Taxacher
It's expected that in the case wher einstaller cannot apply the new paswd because aof a false supplied old passwd the server passwd cannot be set (although i dont see why the passwd on x64 system is "" in that case as opposed to the old passwd on 32bit).

the actual problem is, that re-running the configuration (when you click the "try again" link) is an actual dead-end, since the service is running at this point and the installer refuses to enable the "next" button as long as you keep the port number unchanged (because it sees a mysql server running there).

So when you re-run the configuration, the installer should either shut down the service it started on first configuration attempt or consider the now running service as the one to be reconfigured ...
[30 May 2012 20:34] Javier Rivera Zavala
I tried to reproduce it again and it seems this problem is corrected. Now, a new problem arised which is the Console shortcut doesn't get updated.
[13 Jun 2012 17:57] Javier Rivera Zavala
Unable to reproduce it with latest version (5.5.25.0) http://pan06.se.oracle.com:8080/view/MySQL_Installer/job/MySQL%20Installer%201.0%20Repacka...
[20 Jun 2012 17:04] Javier Rivera Zavala
An enhancement to re-prompt the root password when incorrectly input is programmed for the next Installer version, aiming to solve this problem.
[12 May 2016 17:59] Javier Rivera Zavala
This issue has already been fixed in a previous version.