Bug #61743 Installation Path mess
Submitted: 4 Jul 2011 19:07 Modified: 12 May 2016 17:58
Reporter: Armando Lopez Valencia Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version: OS:Microsoft Windows (Windows 7x86)
Assigned to: Assigned Account CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[4 Jul 2011 19:07] Armando Lopez Valencia
Description:
Installation Path mess

How to repeat:
Repro Steps:
- Make a "developer default" installation.
- In the setup type page Modify the Installation Path and Data Path.
- Finish the installation.

Actual results:
See attachment.

Expected results:
All the packages must be installed in the custom path.
[4 Jul 2011 19:08] Armando Lopez Valencia
Custom path

Attachment: CustomPath.JPG (image/jpeg, text), 80.67 KiB.

[4 Jul 2011 19:22] Armando Lopez Valencia
Installation log

Attachment: PathMess.log (application/octet-stream, text), 308.21 KiB.

[5 Sep 2011 10:30] Papil Mach
I have also a problem with the installer.
I change the installation paths for Mysql and Mysql data.
 - Installation path : D:\softwares\MySQL
 - MySQL data path : D:\softwares\MySQL\data

The problem is that the installer copy files also in the default data directory... (I don't remember exactly the exact directory).
==> The server doesn't work.

If I keep the default directories of MySQL, it works.

For me it's a strong problem because I really want not to have a space character in my installation path (as a lot of developers).
[5 Jun 2012 16:09] Javier Rivera Zavala
Change paths to
 - Installation path : D:\x
 - MySQL data path : D:\x\data
I can reproduce it, but only when performing a full install. when attempt the Server install, everything worked fine.
[6 Jun 2012 17:04] Javier Rivera Zavala
I've been unable to reproduce this bug since yesterday in neither community or commercial msi's, the oldest version I could get is 5.5.16.0, and the latest was 5.5.24.0.

Hope more details about how to reproduce it could be provided:
Commercial/community
file version 5.5.?.?
OS:(tried with Win7x64)
Clean install? (Verify no "MySQL" folders exist on "Program Files" or "ProgramData" folders before running the MSI.)
[15 Jun 2012 15:35] Javier Rivera Zavala
A code fix has been submitted
[12 May 2016 17:58] Javier Rivera Zavala
This issue has already been fixed in a previous version.