Bug #6170 Can't create timezone table with essentials package
Submitted: 20 Oct 2004 8:01 Modified: 20 Oct 2004 22:54
Reporter: Andreas Götz Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.1.16 OS:Windows (WinXP SP1)
Assigned to: CPU Architecture:Any

[20 Oct 2004 8:01] Andreas Götz
After upgrading to 4.1.6, I'm receiving this in the log file:

041007  9:11:19  [WARNING] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them

No sql script for timezone creation is provided.

How to repeat:

Suggested fix:
Please add script to essentials package
[20 Oct 2004 8:10] Andreas Götz
Sorry, I've found the problem:

I had previously upgraded to 4.1, including user privileges, but did not have the timezone tables yet.
Running the upgrade script again requires -f command line switch. Running the upgrade script from inside query browser does not seem possible, always leads to error 2014.

Not sure there is an issue inside?
[20 Oct 2004 22:54] MySQL Verification Team
I tried a fresh install with essential packages and wasn't able to repeat
the behavior reported.
Are you tried to install over an existing MySQL installation ? in this case
the installer not installed the grant tables for to avoid the re-written
[21 Oct 2004 7:27] Andreas Götz
As written initally- I installed ontop of 4.1.3, which was previously upgraded  from 4.0.

The issue- if any- is why QB can't run the upgrade script? It always runs into error 2014...