Bug #61643 Crash on import of DBDesigner file
Submitted: 25 Jun 2011 10:12 Modified: 6 Oct 2011 14:47
Reporter: Michael Härtl Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.34 CE OS:Any (Windows XP, Mac OS X)
Assigned to: CPU Architecture:Any
Tags: crash, DBdesigner
Triage: Needs Triage: D1 (Critical)

[25 Jun 2011 10:12] Michael Härtl
Description:
MySQL Workbench crashes when trying to import a specific DB Designer file.

How to repeat:
Will attach the DBDesigner file.
[25 Jun 2011 10:14] Michael Härtl
Even in case the file is invalid, it should not crash the application. Instead it should give a warning or provide the option to ignore invalid file contents.
[25 Jun 2011 10:36] Michael Härtl
Stack trace from Windows System Event Log

Attachment: StackTrace_Workbench.txt (text/plain), 12.67 KiB.

[25 Jun 2011 11:18] Valeriy Kravchuk
Thank you for the bug report. Verified on Mac OS X also.
[4 Oct 2011 2:30] Alfredo Kojima
The problem is caused by some invalid SQL in the standard inserts defined in
the model for the table "rechnung". The inserts value contains a string with
embedded newlines that seem to have been exported in an invalid/ambiguous
format, which can't be interpreted correctly by WB. Once these newlines are
fixed manually in the model it can be imported without problems.
[6 Oct 2011 14:47] Michael Härtl
Thanks for this, i will fix my file. Still i think, it should not crash WB. Anyway, my problem is solved.