Bug #61476 wrong sql generation during forward engineer
Submitted: 10 Jun 2011 9:53 Modified: 10 Jun 2011 12:34
Reporter: francesco campana Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.34 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: wrong SQL

[10 Jun 2011 9:53] francesco campana
Description:
The sql generated by the application presents some errors.
In particular:

* commas in the wrong place
CREATE  TABLE IF NOT EXISTS `my_coopartemide`.`cat_periodicita` (
  `id` INT NOT NULL AUTO_INCREMENT ,
  `descrizione` VARCHAR(45) NULL ,
  PRIMARY KEY (`id`) ), -- <- Must not be here
COMMENT = 'rappresenta la ricorrenza (quotidiana, settimanale...)' ;

How to repeat:
This behaviour occurs whenever I forward engineer my project.
[10 Jun 2011 12:34] Alfredo Kojima
Duplicate of bug #61393