Bug #61455 unable to convert mysql date time value to "system datetime"
Submitted: 9 Jun 2011 2:55 Modified: 9 Jun 2011 4:37
Reporter: Darryl Stratford Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.4.1 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[9 Jun 2011 2:55] Darryl Stratford
Description:
Generated an Entity Data Model with this version with no problems but get this runtime error when attempting to access a table with a datetime field ...

'unable to convert mysql date time value to "system datetime"'

How to repeat:
Run a LINQ to Entity query
[9 Jun 2011 4:37] Darryl Stratford
Further investigation shows the cause was an invalid datetime value (0000-00-00) in one of the records.

Apologies.