Bug #61253 FileMaker Pro 11 Advanced crashes when using MySQL Driver
Submitted: 21 May 2011 21:25 Modified: 28 May 2013 14:10
Reporter: Michael Tarleton Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:5.1.8 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: 11, Advanced, crash, crashes, filemaker, lookup, Pro, table

[21 May 2011 21:25] Michael Tarleton
Description:
When using FileMaker Pro 11 Advanced to query a table from a remote MySQL server, everything works fine (we can connect to the database, we can see all the tables) except when we try to use a table by selecting it, FileMaker Pro 11 Advanced stops processes of the currently opens database and the database must be closed. 

There is no error generated with this crash. FileMaker itself does not crash, only the FileMaker database crashes. 

How to repeat:
1) Download and install:
• Mac OS X ODBC Administration tool from Apple.com
• MySQL Connector/ODBC ver 5.1.8 from MySQL.com
2) Configure a "System DNS" using the ODBC Administration tool and assign the appropriate DATABASE, SERVER, USERNAME, and PASSWORD parameters. 
3) Open FileMaker Pro Advanced 11
• go to File > Manage > External Data Sources
4) Select "Add ODBC Data Source"
5) Select the System DNS you previously created
6) Now you will see all of the tables in the selected database
7) Select *any* table from the list and click DONE

At this point the FMPA 11 database stops responding. 

Suggested fix:
Download the ActualTech open source drivers and follow the "reproduce" steps.
[22 May 2011 8:32] Valeriy Kravchuk
Similar to/duplicate of bug #56435.
[17 Dec 2011 14:19] Valeriy Kravchuk
We do not have access to FileMaker software. So, please, try to use 32-bit version of 5.1.8 (or build 5.1.9 from source) and check if this solves the problem.
[18 Jan 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[18 May 2012 3:18] roger helton
I am having the same problem now. But this only happened after a reformat HD and reinstalled 10.6 and bootcamp and Win 7. Before this I had success in connecting to the mysql DB hosted, with either OS. But sometimes it took several attempts before was able to connect. If I use mysql odbc connector or Actual Tech. the results was pretty much the same. 
Just dont understand why after the new installs having this problem.
[24 Jul 2012 10:41] Mario Pietro
Excuse me for my english!
I have the same problem!
With FileMaker 11 or 12 and Mac OS X 10.6.8 i can see the tables but when i try to use them File Maker crashes..
Thanks for every consideration You will write..
[14 Nov 2012 9:42] Bogdan Degtyariov
Have you tried the new version 5.5.2? It should resolve the problem.
[15 Dec 2012 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 14:10] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.