Bug #61085 MySQL Workbench 5.2.33b Crash on Start-up [SOLVED]
Submitted: 6 May 2011 20:36 Modified: 6 Oct 2011 8:41
Reporter: Brian Sleeth Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.33b, 5.2.34 OS:Windows (Vista Home Premium 64-Bit)
Assigned to: CPU Architecture:Any

[6 May 2011 20:36] Brian Sleeth
MySQL Workbench crashes on startup.  Splash screen is shown for a few seconds before program terminates.

NOTE: A similar crash was reported und bug # 61014 
However, I tested the provided solution for that bug, version, and continue to crash on startup.

Following are the details from the windows crash report and event logs:

========== WINDOWS CRASH REPORT ========== 
  Stopped working

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:
  Application Timestamp:	4d820632
  Fault Module Name:	base.dll
  Fault Module Version:
  Fault Module Timestamp:	4d82005b
  Exception Code:	c0000005
  Exception Offset:	00005e7e
  OS Version:	6.0.6002.
  Locale ID:	1033

Read our privacy statement:
========== WINDOWS CRASH REPORT ========== 

========== APPLICATION EVENT LOG 1 ==========
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2011-05-06T20:25:23.000Z" />
    <Security />
========== APPLICATION EVENT LOG 1 ========== 

========== APPLICATION EVENT LOG 2 ==========
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name=".NET Runtime" />
    <EventID Qualifiers="0">1026</EventID>
    <TimeCreated SystemTime="2011-05-06T20:25:38.000Z" />
    <Security />
  <Data>Application: MySQLWorkbench.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException Stack: at <Module>.wb.WBContextUI.init(wb.WBContextUI*, wb.WBFrontendCallbacks*, wb.WBOptions*) at MySQL.Workbench.WbContext.init(MySQL.Forms.AppImpl, MySQL.Workbench.WbOptions, VoidStrUIFormDelegate) at MySQL.GUI.Workbench.Program.Main(System.String[])</Data>
========== APPLICATION EVENT LOG 2 ========== 

How to repeat:
Start the workbench via shortcut or double-clicking the program from Windows Explorer.

Suggested fix:
Don't crash on startup.
[28 May 2011 11:07] Valeriy Kravchuk
Please, remove your current version (including *.pyc files, see http://wb.mysql.com/?p=1068 for details), install 5.2.34 GA and check if it still crashes in your environment.
[30 May 2011 18:39] Brian Sleeth
Still crashes on fresh install of .NET 4 and MYSQL Workbench 5.2.34 CE.
[7 Jun 2011 14:50] Romain Muller
I'm having the same symptoms on Windows 7 x64, MySQL Workbench 5.2.34 CE (GA).
[7 Jun 2011 17:25] Armando Lopez Valencia
Hello Brian and Romain.
Can you please provide you system information? (in workbench -> Help -> system Info).
[7 Jun 2011 17:48] Brian Sleeth
As we cannot start the workbench, it would be pretty hard to use "Workbench -> Help -> System Info" to provide the information.

As such, I have attached the MSINFO32 output (both the .nfo and txt report).
[7 Jun 2011 17:50] Brian Sleeth
System Information (MSINFO32) Output from Brian's System

Attachment: MsInfoBrian.zip (application/zip, text), 106.60 KiB.

[14 Jun 2011 16:22] Joe Burchett
I can confirm the same issue for both versions 5.2.33b and 5.2.34, using Windows 7 Enterprise and .NET 4.0, with a fresh/clean install (no *.pyc files) for both versions.  

CPU is an i5 M520.
[28 Jun 2011 12:55] Johannes Taxacher
Hello Brian,
can you try to start workbench using the commandline parameter -swrendering (this forces WB to start without openGL support) ... just to check that we can rule out problems with gfx drivers.
thanks in advance
[1 Jul 2011 21:18] Brian Sleeth
Still crashes with the -swrendering switch.

I performed the test using a fresh install of  I also, disconnected my second monitor and did a cold restart of my system and it still crashed.  I ran the test both from a link (shortcut) and from a DOS prompt.  When running from the DOS prompt, the following error was written to the DOS window before the standard windows crash dialog popped up:

Unhandled Exception: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at wb.WBContextUI.init(WBContextUI* , WBFrontendCallbacks* , WBOptions* )
   at MySQL.Workbench.WbContext.init(AppImpl application, WbOptions options, VoidStrUIFormDelegate create_main_form_view)
   at MySQL.GUI.Workbench.Program.Main(String[] Args)
[9 Jul 2011 11:44] Ido Freeman
I'd like to report the very same thing under win7 x64, can't get in to load. i've read somewhere in here i can delete some folder and that might help but i cannot find that folder.
[9 Jul 2011 14:38] Ido Freeman
Problem Solved!
after looking at many bugs quite similar to mine, i noticed that many of the people experiencing the same type of issues use ATI graphic cards, updating my Catalyst drivers to the latest version seems to have fixed it for me.
thank you
[9 Jul 2011 18:40] Brian Sleeth
Glad you found a fix for your system.  

I have an NIVIDIA GeForce 9600M GT graphics card.  I have been keeping up-to-date with Microsoft Update, but went ahead and downloaded the latest drivers for my card from the NIVIDIA site.

Still crashes for me even after updating and a cold reboot.
[13 Jul 2011 13:05] Adriano Cisternino
I will also add my findings here. Here is what I did in this exact order ....

I installed 5.0.30 - Works perfectly
I installed - Crashes on Startup (5.0.30 is still there and running)
I removed
I removed 5.0.30
I checked that there were no folders, files left
I rebooted
I installed - Still crashes on startup as before
I removed it
I installed 5.2.32 - Also crashes as
I removed it
I installed 5.2.26 - It works!!!

My setup is 

OS: Windows 7 Ultimate 32bit - SP1 with all the updates
CPU: Intel QuadCore Q9650 
NVIDIA 8800GTS - Driver version 197.45

Should I try updating the NVIDIA drivers???

[13 Jul 2011 13:43] Adriano Cisternino
One more thing ....

Considering that I am now able to run version 5.2.26 I thought I post my System Info

MySQL Workbench CE for Windows version 5.2.26
Data Directory: K:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 3.2.0
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 32-bit
CPU: 4x Intel(R) Core(TM)2 Quad CPU    Q9650  @ 3.00GHz, 3.3 GiB RAM
Video adapter info:
Adapter type: NVIDIA GeForce 8800 GTS 
Chip Type: GeForce 8800 GTS
BIOS String: Version 60.80.a.0.2
Video Memory: 655360 KB
[10 Aug 2011 13:34] Alfredo Kojima
Anyone having this crash where the stack contains something like:
System.AccessViolationException Stack: at <Module>.wb.WBContextUI.init(wb.WBContextUI*,
wb.WBFrontendCallbacks*, wb.WBOptions*) at

Please enable crashdumps ( http://forums.plexapp.com/index.php/topic/23320-enabling-automatic-crash-dumps-on-windows/  has instructions on enabling) and send the dmp file for WB. Thanks!
[11 Aug 2011 0:11] Brian Sleeth
Just re-downloaded and re-installed v5.2.34.  Still crashes.

Oddly, this time it required me to download and install the C++ 2010 redist.  Go figure?!?

I will attach the requested crash dump.
[11 Aug 2011 0:35] Brian Sleeth
Well ... I thought I would upload the file.

As the raw file is very large (11MB), I created the archive following the instructions on the upload page.  The size is now around 3MB.

The problem is the ftp.mysql.com is not reachable.

Any suggestions on how to upload the crash dump file?
[31 Aug 2011 1:02] Alfredo Kojima
What version of the MSVC2010 redistributables did you install? 64 or 32bit?
The one Workbench needs is 32bit, so if you installed 64bit only that would be the reason. Please check.
[31 Aug 2011 8:39] Brian Sleeth
Actually, I had only installed the x86 version of the MSVC 2010 Redistributable.

I installed the 64-bit version and re-installed the x86 version.

Still crashed.  Rebooted.  Uninstalled and re-installed workbench.  Rebooted.

Still crashes.
[31 Aug 2011 9:00] Mike Lischke
Brian, thanks a lot for trying to help with that issue. Please try the non-msi WB package and see if that runs. It doesn't need installation, just unzip and run it. If it runs can you compare the two folders to see if there are any differences?
[31 Aug 2011 9:09] Mike Lischke
Brian, could you also post your PATH var here, so we can see if any other software is in the way that might conflict with WB? You can get that from a command prompt. Type "set" and copy the PATH setting from the output.

[31 Aug 2011 16:38] Brian Sleeth
Directory comparison between the ZIP and MSI installs (after having attempted to run both).

Attachment: bug-data-61085-zip_vs_msi_directory_diff.pdf (application/pdf, text), 65.07 KiB.

[31 Aug 2011 16:40] Brian Sleeth
The ZIP "install" also crashed.

I attached the bug-data-61085-zip_vs_msi_directory_diff.pdf file which lists the directory differences between the ZIP and MSI installs.  The comparison was made after having attempted to run the workbench.

After running the directory comparison, I uninstalled the MSI version, rebooted, and attempted to run the ZIP "install" once again.  And, once again, it still crashes.
[21 Sep 2011 20:06] Armando Lopez Valencia
Can you please try with the suggestion in this bug:
Please let us know your results.
[21 Sep 2011 20:52] Brian Sleeth
My system (Windows 7) has both Tahoma font files installed (regular and bold).  The font files appear to match a Vista and I am able to select the font from various applications.  As such, I do not see a need to re-install the font.

So ... am I the ONLY person having this problem or what?!?!
[25 Sep 2011 11:08] Rauno Ots
Fixed by updating ATI drivers.
[26 Sep 2011 4:13] Brian Sleeth
Yes, updating ATI drivers was reported to resolve this problem back on 09-Jul-2011 by Ido Freeman.

My graphics card is an NVIDIA card.  Updating this driver DOES NOT solve the problem.  Most recently checked with version 280.26.
[3 Oct 2011 10:07] Kristian Arlt
Fixed by installing x86 Redist instead of x64 onto Win7 64bit
[3 Oct 2011 18:04] Brian Sleeth
In my situation, installing/reinstalling the x86 and 64-bit redist did not help ... it was a good idea, but did not help.
[3 Oct 2011 19:50] Brian Sleeth
[SOLVED] ... well, sort of ...

I recently upgraded/updated to MySQL Community Edition version 5.5.16 64-bit.

I did a clean install of the workbench (using MSI installer) and it is now working.

To the best of my knowledge no other changes were made to the system.  I do not know why this "fixed" the problem, but it did.

Good luck to anyone else having this problem.
[5 Oct 2011 9:50] Valeriy Kravchuk

What exact version of Workbench you had installed this time? Recent 5.2.35 maybe?
[5 Oct 2011 17:38] Brian Sleeth
Duh!!! ... Yes! I, installed version 5.2.35.

Thanks for catching this.  Sorry, I did not notice the new version.

That makes a lot more since than the updated MySQL version.

Again, sorry for not noticing the version change.
[6 Oct 2011 8:41] Valeriy Kravchuk
Not repeatable with 5.2.35.
[30 Oct 2011 12:59] paul lupu
I have the radeon 6850 with the most up-to-date drivers from amd, installed the Microsoft C++ or C# thing that was required, still crashes on startup, unable to finish my school assignment because of this.
[1 Apr 2012 15:04] Radek Mar
I had the same problem... and if you have two graphics processors the solution is
to force running Workbench with integrated graphics instead of Nvidia ION (my netbook is ASUS EEEPc 1225N)