Bug #60953 Attempted to read or write protected memory
Submitted: 22 Apr 2011 18:31 Modified: 25 Apr 2011 22:45
Reporter: Patrick Zwick Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.33 OS:Any
Assigned to: CPU Architecture:Any

[22 Apr 2011 18:31] Patrick Zwick
Description:
Here is the requested Stack:

Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql(Boolean sync)
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSql(Boolean sync)
   at MySQL.Grt.Db.Sql.SqlEditor.RunBackgroundAction(Boolean sync)
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I'm just typing away, and suddenly...BOOM! I'm hit with this bug and have to restart. Not fun.

How to repeat:
I haven't been typing for long, and it's usually not when I'm even typing something new. I'm just arrowing (or whatever you call it) through text I've written already, and then I'm hit with this bug. Not sure how to repeat it.

Suggested fix:
Wish I knew.
[22 Apr 2011 19:09] Valeriy Kravchuk
Please, send the output of Help > System Info menu item.
[22 Apr 2011 21:05] Patrick Zwick
I just upgraded to My SQL Workbench 5.2.33, so I'm not sure if this will be useful, but here is what I get (thanks, by the way!):

Started HTTP server on port 2392.

"GET / HTTP/1.1" 301 -

"GET /webui/index.wbp HTTP/1.1" 200 -

"GET /webui/stylesheets/ui.css HTTP/1.1" 200 -

"GET /webui/stylesheets/ui.css HTTP/1.1" 200 -

"GET /webui/images/1ptrans.gif HTTP/1.1" 200 -

"GET /webui/images/toolbar_forward.png HTTP/1.1" 200 -

"GET /webui/images/toolbar_back.png HTTP/1.1" 200 -

"GET /webui/images/toolbar_refresh.png HTTP/1.1" 200 -

"GET /webui/document_browser.wbp HTTP/1.1" 200 -

"GET /webui/docs_index.html HTTP/1.1" 200 -

"GET /webui/images/toolbar_sep.png HTTP/1.1" 200 -

"GET /webui/images/panel_header_bg.png HTTP/1.1" 200 -

"GET /webui/images/panel_bottom_tab_bg.png HTTP/1.1" 200 -

----------------------------------------

Exception happened during processing of request from ('127.0.0.1', 2407)

Traceback (most recent call last):

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\SocketServer.py", line 281, in _handle_request_noblock

    self.process_request(request, client_address)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\SocketServer.py", line 307, in process_request

    self.finish_request(request, client_address)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\SocketServer.py", line 320, in finish_request

    self.RequestHandlerClass(request, client_address, self)

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\SocketServer.py", line 615, in __init__

    self.handle()

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\BaseHTTPServer.py", line 329, in handle

    self.handle_one_request()

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\BaseHTTPServer.py", line 312, in handle_one_request

    self.raw_requestline = self.rfile.readline()

  File "C:\Program Files\MySQL\MySQL Workbench 5.2 CE\python\socket.py", line 406, in readline

    data = self._sock.recv(self._rbufsize)

error: [Errno 10054] An existing connection was forcibly closed by the remote host

----------------------------------------

Query: search=default+database&manual_type=0

Search started, search_string: default database, manual_type: 0

"GET /webui/search.wbp?search=default+database&manual_type=0 HTTP/1.1" 200 -

"GET /webui/stylesheets/ui.css HTTP/1.1" 200 -

Query: search=set+default+database&manual_type=0

Search started, search_string: set default database, manual_type: 0

"GET /webui/search.wbp?search=set+default+database&manual_type=0 HTTP/1.1" 200 -

Query: search=default+database&manual_type=0

Search started, search_string: default database, manual_type: 0

"GET /webui/search.wbp?search=default+database&manual_type=0 HTTP/1.1" 200 -

"GET /webui/stylesheets/ui.css HTTP/1.1" 200 -

code 404, message An error occurred. error(10054, 'An existing connection was forcibly closed by the remote host')

"GET /webui/stylesheets/ui.css HTTP/1.1" 404 -

Error:  An error occurred while opening the database connection. error(10054, 'An existing connection was forcibly closed by the remote host')

MySQL Workbench CE for Windows version 5.2.33

Configuration Directory: C:\Documents and Settings\dzwick\Application Data\MySQL\Workbench

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, but GDI was requested. Using GDI for rendering.

OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)

CPU: 2x Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz, 3.5 GiB RAM

Active video adapter: Mobile Intel(R) 965 Express Chipset Family

Installed video RAM: 384 MB

Current video mode: 1280 x 800 x 4294967296 colors

Used bit depth: 32

Driver version: 6.14.10.5076

Installed display drivers: igxprd32.dll

Current user language: English (United States)

MySQL Workbench CE for Windows version 5.2.33

Configuration Directory: C:\Documents and Settings\dzwick\Application Data\MySQL\Workbench

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, but GDI was requested. Using GDI for rendering.

OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)

CPU: 2x Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz, 3.5 GiB RAM

Active video adapter: Mobile Intel(R) 965 Express Chipset Family

Installed video RAM: 384 MB

Current video mode: 1280 x 800 x 4294967296 colors

Used bit depth: 32

Driver version: 6.14.10.5076

Installed display drivers: igxprd32.dll

Current user language: English (United States)
[23 Apr 2011 23:18] Miguel Solorzano
Thank you for the feedback. You don't have any clue how was the exactly sequence of actions to get that issue?. Thanks in advance.
[25 Apr 2011 16:59] Patrick Zwick
Unfortunately not. It's happened to me a few times now, and I can't predict when it will happen. I'll just be typing along and then suddenly this error pops up. I know that doesn't help much with debugging.
[25 Apr 2011 22:45] Alfredo Kojima
This appears to be a duplicate of bug #56034