Bug #60934 MySQL installer reports notes as errors
Submitted: 20 Apr 2011 14:31 Modified: 13 Dec 2016 13:54
Reporter: Giuseppe Maxia Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.6.2 OS:Any
Assigned to: CPU Architecture:Any
Tags: installer, verbose
Triage: Needs Triage: D4 (Minor)

[20 Apr 2011 14:31] Giuseppe Maxia
Description:
When running mysqld in bootstrap mode, the server usually reports errors in the standard error, which eventually ends up in the error log.

For example:

./scripts/mysql_install_db --no-defaults  --basedir=$PWD --datadir=$PWD/data 
Installing MySQL system tables...
110420 13:24:50 [Note] Binlog end
110420 13:24:50 [Note] Shutting down plugin 'partition'
110420 13:24:50 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_METRICS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMPMEM'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMP_RESET'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMP'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_LOCKS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_TRX'
110420 13:24:50 [Note] Shutting down plugin 'BLACKHOLE'
110420 13:24:50 [Note] Shutting down plugin 'ARCHIVE'
110420 13:24:50 [Note] Shutting down plugin 'MRG_MYISAM'
110420 13:24:50 [Note] Shutting down plugin 'MyISAM'
110420 13:24:50 [Note] Shutting down plugin 'MEMORY'
110420 13:24:50 [Note] Shutting down plugin 'CSV'
110420 13:24:50 [Note] Shutting down plugin 'mysql_old_password'
110420 13:24:50 [Note] Shutting down plugin 'mysql_native_password'
110420 13:24:50 [Note] Shutting down plugin 'binlog'
OK
Filling help tables...
110420 13:24:50 [Note] Binlog end
110420 13:24:50 [Note] Shutting down plugin 'partition'
110420 13:24:50 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_METRICS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMPMEM'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMP_RESET'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_CMP'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_LOCKS'
110420 13:24:50 [Note] Shutting down plugin 'INNODB_TRX'
110420 13:24:50 [Note] Shutting down plugin 'BLACKHOLE'
110420 13:24:50 [Note] Shutting down plugin 'ARCHIVE'
110420 13:24:50 [Note] Shutting down plugin 'MRG_MYISAM'
110420 13:24:50 [Note] Shutting down plugin 'MyISAM'
110420 13:24:50 [Note] Shutting down plugin 'MEMORY'
110420 13:24:50 [Note] Shutting down plugin 'CSV'
110420 13:24:50 [Note] Shutting down plugin 'mysql_old_password'
110420 13:24:50 [Note] Shutting down plugin 'mysql_native_password'
110420 13:24:50 [Note] Shutting down plugin 'binlog'
OK

How to repeat:
use mysql_install_db with an expanded binary tarball

Suggested fix:
Let bootstrap issue notes to the standard output, and errors to the standard error.
This ambiguity is confusing.
[28 Apr 2011 11:35] Valeriy Kravchuk
I can confirm that bootstrap notes goes to stderr. Request to change this is a feature request.
[28 Apr 2011 12:30] Giuseppe Maxia
This is not a feature request. It is a regression. Until MySQL 5.5, bootstrap uses STDERR for errors only.
[9 Aug 2013 19:55] Bob Strini
May not be related but the MySQL installer downloaded today (9 Aug 2013) has a bad URL for downloading MySQL-visualstudio-plugin-win32.  Returns 404 error. Your site does not have a manual way to download the file (can't even find it) and not sure how the installer will know where to look for it on my computer if is hardwired to the URL.

Bob
[24 Sep 2013 17:33] Giuseppe Maxia
This issue was resolved (or at least greatly improved) in MySQL 5.7.2. 
Should the bug be updated with some info on what's been done and whether it is final?
[13 Dec 2016 13:54] Erlend Dahl
[13 Dec 2016 1:27] Yngve Svendsen 

Closing this since it was fixed in the 5.7 cycle. Bug should have been
updated with more information at the time, but that was unfortunately not
done.