Bug #60855 Conflict between "shared" and "shared-compat"
Submitted: 13 Apr 2011 12:46 Modified: 22 Mar 2012 17:41
Reporter: Edward shaw Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.6.2 m5 OS:Linux
Assigned to: CPU Architecture:Any
Tags: regression
Triage: Needs Triage: D3 (Medium)

[13 Apr 2011 12:46] Edward shaw
Description:
This bug was fixed in 5.5.6 ( http://bugs.mysql.com/bug.php?id=56150 )
And now it happened on 5.6.2 m5 again

Package 'shared' have 'libmysqlclient.so' but 'shared-compat' doesn't have it
But they can't be installed together

[root@server ~]# rpm -qlp MySQL-shared-5.6.2_m5-1.rhel5.x86_64.rpm
/usr/lib64/libmysqlclient.so
/usr/lib64/libmysqlclient.so.16
/usr/lib64/libmysqlclient.so.16.0.0
/usr/lib64/libmysqlclient_r.so
/usr/lib64/libmysqlclient_r.so.16
/usr/lib64/libmysqlclient_r.so.16.0.0
[root@server ~]# rpm -qlp MySQL-shared-compat-5.6.2_m5-1.rhel5.x86_64.rpm
/usr/lib64/libmysqlclient.so.12
/usr/lib64/libmysqlclient.so.12.0.0
/usr/lib64/libmysqlclient.so.14
/usr/lib64/libmysqlclient.so.14.0.0
/usr/lib64/libmysqlclient.so.15
/usr/lib64/libmysqlclient.so.15.0.0
/usr/lib64/libmysqlclient.so.16
/usr/lib64/libmysqlclient.so.16.0.0
/usr/lib64/libmysqlclient_r.so.12
/usr/lib64/libmysqlclient_r.so.12.0.0
/usr/lib64/libmysqlclient_r.so.14
/usr/lib64/libmysqlclient_r.so.14.0.0
/usr/lib64/libmysqlclient_r.so.15
/usr/lib64/libmysqlclient_r.so.15.0.0
/usr/lib64/libmysqlclient_r.so.16
/usr/lib64/libmysqlclient_r.so.16.0.0

How to repeat:
Install two package together. 

Suggested fix:
Fix it just like what you have done in 5.5.6
[14 Apr 2011 3:10] Valeriy Kravchuk
Check comment dated 

[13 Apr 17:09] Joerg Bruehe

in bug #56150. This is, indeed, a bug.
[16 Sep 2011 20:24] Ask Bjørn Hansen
This is also a problem in 5.5.15 (since 5.5.10 I think).
[1 Oct 2011 3:08] noneya bidniss
the fix for bug #56150 (rightly) made the contents of these two packages able to coexist.  Some regression since then has made it not possible (from rpm's point of view) to install them together.  I suspect the .spec file for shared-compat has reverted to its previous state of "obsoleting" shared.  I can confirm that this regression has been in place since at least 5.5.11.
[22 Mar 2012 17:41] Paul Dubois
Noted in 5.5.22, 5.6.5 changelogs.

The contents of the shared and shared-compat RPM packages had been
changed in versions 5.5.6 and 5.6.1 to avoid the overlap which they
traditionally had (and still have in MySQL 5.0 and 5.1). However, the
RPM meta information had not been changed in accordance, and so RPM
still assumed a conflict between shared and shared-compat RPM
packages. This has been fixed.
[21 May 2012 9:07] Yunyang Zhang
I want to know where is the MySQL-shared-compat spec file.
Anyone can help me?