Bug #60754 agent RPM's gone from edelivery
Submitted: 4 Apr 2011 15:24 Modified: 5 Apr 2011 18:09
Reporter: Daniël van Eeden Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Enterprise Monitor: Documentation Severity:S2 (Serious)
Version:2.3.2 OS:Linux
Assigned to: John Russell CPU Architecture:Any
Tags: rpm
Triage: Needs Triage: D3 (Medium)

[4 Apr 2011 15:24] Daniël van Eeden
Description:
V23981-01 = 2.3.1.2044
V25178-01 = 2.3.2.2054

For 2.3.2 the agent RPM is gone.

$ unzip -l V25178-01.zip
Archive:  V25178-01.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
 32676203  2011-03-01 17:00   mysqlmonitoragent-2.3.2.2054-linux-glibc2.3-x86-64bit-installer.bin
 32676307  2011-03-01 17:00   mysqlmonitoragent-2.3.2.2054-linux-glibc2.3-x86-64bit-update-installer.bin
---------                     -------
 65352510                     2 files

$ unzip -l V23981-01.zip
Archive:  V23981-01.zip
  Length      Date    Time    Name
---------  ---------- -----   ----
 32673984  2010-12-03 19:06   mysqlmonitoragent-2.3.1.2044-linux-glibc2.3-x86-64bit-installer.bin
 31730064  2010-12-03 19:06   mysqlmonitoragent-2.3.1.2044-linux-glibc2.3-x86-64bit-installer.rpm
 32674079  2010-12-03 19:06   mysqlmonitoragent-2.3.1.2044-linux-glibc2.3-x86-64bit-update-installer.bin
---------                     -------
 97078127                     3 files

How to repeat:
Compare current en previous downloads

Suggested fix:
Add the RPM again or document why it went away.
[5 Apr 2011 8:05] Valeriy Kravchuk
Looks like this change was intended and should be just documented.
[5 Apr 2011 18:09] Gary Whizin
Sorry but there's nothing to document because the mistake was actually having a new packaging script pick up the prototype rpm to begin with. We have fixed the packaging script, we have fixed the tests that missed detecting the new file in the packaging...

Meanwhile, we also have several logged requests for rpm support, but we don't currently support installing via rpm.

Side note: I can't find any formal request to add rpm support; Daniël, feel free to open one if you want to be notified if/when it's available, have us contact you when if/when it's time to beta test, etc.