Bug #60578 Running Mysql internally on Mac OSx 10.6.6,problems opening configuration.
Submitted: 22 Mar 2011 7:45 Modified: 19 May 2011 14:27
Reporter: John McBeath Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.5.10 OS:Mac OS X (Snow Leopard10.6.6)
Assigned to: CPU Architecture:Any
Tags: Problems with configuration file.

[22 Mar 2011 7:45] John McBeath
Description:
On opening workbench to work on database (Configuration tab). Informed that my.cnf is not there. Will be rebuilt after editing.I put new one in last night 21/3/2011.Next box tells me 'File data is not in expected format. This is a bug etc.
 Have had problems getting MySQL to start, tracked down to my.cnf error. Now telling me same after stopping and starting.
Sometimes will not start from shell or stop either.
Change rights on my.cnf and it restarts without it,
Connected on internal pipe.
No problems with external server.(Different server altogether)

Also have error calling WbAdmin.OpenSecurityManager in bottom of window when this happens too.

How to repeat:
Stop and start MySQL from Preferences Pane. When does this no response from terminal apart from to kill.

Suggested fix:
Allow to run from GUI and Terminal (Shell) at same time. Seems to like to use one or the other, but not swapping between, especially at same time.Allow to use configuration files in order listed in manual.
Seems to try all conf files and gets confused.
[22 Mar 2011 8:18] Valeriy Kravchuk
Looks like we need more details:

1. Where is my.cnf really located? Is it possible to start server from command line using this my.cnf?
2. How exactly you had created server instance in Workbench and what path to my.cnf you set there.
3. Why do you think there is a bug in Workbench in this case?
[22 Mar 2011 20:27] John McBeath
Will get back to you once I have another look and see if I did something wrong. Used same file that I used for 5.1.50 and it is located in/etc/my.cnf 
Bug report was sent as WB showed message to send with info.
Not yet using for real hence on internal. Studying at the moment and college don,t give admin or root rights to 1st yrs.
Have it running now but took out my.cnf. Will try with one of new ones from 5.5.10.
[25 Mar 2011 9:28] John McBeath
Solved problem with starting and stopping Mysql. Created new my.cnf in workbench but it would't save.
For some reason when created it has the wrong permissions. Workbench set permissions as 444 (everyone read only) Whilst waiting to save file in workbench used terminal (shell) to change permissions to 644 now workbench can write to file and problem solved. Initially although creating my.cnf and putting file in /etc/ there was nothing in it.
Can now swap between whatever I like, Workbench,Terminal, or PHP scripts.
Don't know why Workbench makes cnf file with 444 permissions as it can't be written. Only reason I can think of is to save mistakingly updating. Just checked to see if permissions at 440 work and cnf used but can't be altered.
So if need new cnf file have to start making file try to save, change permissions in terminal, let file be written, change permissions back in terminal, hey presto!
Bit long winded but it works. 
P.S Now running Snow Leopard 10.6.7.
[19 Apr 2011 14:27] Miguel Solorzano
So the issue was resolved?. Thanks in advance.
[19 May 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".