Bug #60475 BUG on Create Statement
Submitted: 15 Mar 2011 14:18 Modified: 14 May 2011 15:57
Reporter: Samuele Arcolace Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.33 OS:Microsoft Windows (7 Home Premium)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D1 (Critical)

[15 Mar 2011 14:18] Samuele Arcolace
Description:
Look on How to repeat section...

How to repeat:
Create this table and try to click with the right button of the mouse on this table, and then click: Send to SQL Editor, and then to Create Statement. You will now the Unexpected Error....

delimiter $$

CREATE TABLE `tbl_user` (
  `user_id` int(11) unsigned NOT NULL AUTO_INCREMENT,
  `user_name` varchar(100) COLLATE latin1_general_ci DEFAULT NULL COMMENT 'Nome e Cognome dell''utente',
  `user_display` varchar(50) COLLATE latin1_general_ci NOT NULL COMMENT 'Nickname da mostrare nei contest',
  `user_email` varchar(100) COLLATE latin1_general_ci NOT NULL,
  `user_pass` varchar(32) COLLATE latin1_general_ci NOT NULL,
  `user_image` varchar(100) COLLATE latin1_general_ci DEFAULT NULL,
  `user_birth` date DEFAULT NULL,
  `user_gender` enum('M','F') COLLATE latin1_general_ci DEFAULT NULL,
  `country_show` enum('Y','N') COLLATE latin1_general_ci NOT NULL DEFAULT 'N' COMMENT 'Bool per decidere se mostrare o meno la propria nazionalità',
  `home_url` varchar(255) COLLATE latin1_general_ci DEFAULT NULL,
  `user_biography` text COLLATE latin1_general_ci,
  `user_addr1` varchar(255) COLLATE latin1_general_ci DEFAULT NULL,
  `user_addr2` varchar(255) COLLATE latin1_general_ci DEFAULT NULL,
  `user_city` varchar(30) COLLATE latin1_general_ci DEFAULT NULL,
  `user_state` varchar(30) COLLATE latin1_general_ci DEFAULT NULL,
  `user_zip` varchar(30) COLLATE latin1_general_ci DEFAULT NULL,
  `user_country` int(3) DEFAULT NULL,
  `user_phone` varchar(20) COLLATE latin1_general_ci DEFAULT NULL,
  `imp_chnange` enum('Y','N') COLLATE latin1_general_ci NOT NULL DEFAULT 'Y' COMMENT 'Bool per ricevere o meno notifiche da BestCreativity',
  `email_offers` enum('Y','N') COLLATE latin1_general_ci NOT NULL DEFAULT 'N' COMMENT 'Bool per ricevere o meno le newsletter',
  `join_date` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP,
  `unpaid_balance` double DEFAULT NULL,
  `won_balance` double DEFAULT NULL,
  `contest_created` int(11) DEFAULT NULL,
  `contest_won` int(11) DEFAULT NULL,
  `contest_participate` int(11) DEFAULT NULL,
  `is_active` enum('Y','N') COLLATE latin1_general_ci NOT NULL DEFAULT 'N',
  `act_code` varchar(32) COLLATE latin1_general_ci NOT NULL COMMENT 'Codice che viene mandato per email per attivare l''account',
  PRIMARY KEY (`user_id`)
) ENGINE=InnoDB AUTO_INCREMENT=2194 DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci$$
[15 Mar 2011 14:38] Miguel Solorzano
Thank you for the bug report. Verified as describe.
[15 Mar 2011 14:40] Valeriy Kravchuk
Stack trace is:

Exception = System.ArgumentOutOfRangeException
Message = Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
FullText = System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: startIndex
   at System.String.ToCharArray(Int32 startIndex, Int32 length)
   at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.SendMessageDirectWithLength(UInt32 msg, Int32 wParam, String lParam)
   at ScintillaNet.Scintilla.ScintillaNet.INativeScintilla.AddText(Int32 length, String s)
   at MySQL.Grt.Db.Sql.SqlEditor.DoInsertText(String text)
   at MySQL.Grt.RunWrappedDelegate1<int\,int\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> >\,System::String ^\,MySQL::Grt::DelegateSlot1<int\,int\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> >\,System::String ^>::ManagedDelegate>.native_callback(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a1)
   at sigc.pointer_functor1<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,int>.()(pointer_functor1<std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,int>* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* _A_a1)
   at sigc.adaptor_functor<sigc::pointer_functor1<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,int> >.operator()<class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > const &>(adaptor_functor<sigc::pointer_functor1<std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,int> >* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* _A_arg1)
   at sigc.internal.slot_call1<sigc::pointer_functor1<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,int>,int,std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &>.call_it(slot_rep* rep, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a_1)
   at MySQL.Grt.ListModel.activate_popup_item_for_nodes(String name, List`1 nodes)
   at MySQL.GUI.Workbench.ModelOverviewForm.PopupActionHandler(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
[15 Mar 2011 16:35] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=60375 marked as duplicate of this one.
[23 Mar 2011 19:55] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=60592 marked as duplicate of this one.
[14 May 2011 15:58] Paul Dubois
Noted in 5.2.34 changelog.

Workbench crashed trying to execute some CREATE TABLE statements.