Bug #60445 VS 2010 MySql Website Configuration Tool bot working after applying SP1
Submitted: 12 Mar 2011 23:03 Modified: 30 Jul 2011 7:54
Reporter: Max Floden Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.3.6 OS:Microsoft Windows (Win7 64-bit, Visual Studio 2010)
Assigned to: Assigned Account CPU Architecture:Any
Tags: .net, connector, Visual Studio, vs

[12 Mar 2011 23:03] Max Floden
Description:
I had MySQL Connector 6.3.2 beta installed with MySql Website Configuration Tool working in Visual Studio 2010 for web projects, ie the MySql Website Configuration Tool icon showed up in Solution Explorer in VS (as described here: http://dev.mysql.com/doc/refman/5.5/en/connector-net-website-config.html)

After applying VS 2010 SP1 (service pack 1) i did get a popup window with some kind if error msg re Mysql first I restarted vs2010 (unfortunately I did not record message). MySql Website Configuration Tool icon was now gone.

I uninstalled 6.3.2 beta and installed 6.3.6 (msi installer) It reports it has installed correctly but still no MySql Website Configuration Tool icon shows in Solution Explorer neither for Web site or Web project. Ran msi installer again and clicked Repair but still not working.

How to repeat:
Have not attempted.
- Try to install connector on VS2010 with SP1
- OR: Try to install connector on VS2010 without SP1 (should work, ie MySql Website Configuration Tool icon showing in Solution Explorer in VS2010) and then apply SP1 (should no longer work)

Suggested fix:
Fix please or provide workaround (eg. is there a way to run the MySql Website Configuration Tool other than clicking Icon in Solution Explorer?)
[13 Mar 2011 11:23] Max Floden
I tried to uninstall connector, do devenv.exe /ResetSettings + devenv.exe /resetuserdata + reinstall connector, to no avail
[16 Jun 2011 12:42] Bogdan Degtyariov
Hi Max,

I tried to repeat the bug with the Website Configuration Tool. All steps went without any errors in VS 2010 SP1.

On which stage did you get the error message? Was that after clicking FINISH?
[16 Jul 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[17 Jul 2011 6:04] Max Floden
Hi,

I got the error message after applying sp1 to vs2010 and then the first time starting vs2010 with sp1 installed. (so i had vs2010 installed without sp1 and mysql connector working, then installed sp1, got error, and website config tool stopped working)

Br Max
[29 Jul 2011 14:35] Julio Casal
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the original bug instead.

Dupplicate of bug #60723.

Thank you for your interest in MySQL.
[30 Jul 2011 7:54] Max Floden
Ok happy to see you have fixed it. 
Just a side note: my bug report was submitted 2 weeks before the duplicate so - at least in this universe - it was not possible for me to find it when searching ;)
[1 Aug 2011 18:48] Julio Casal
I'm sorry for that. For some reason I didn't see your bug before the other one. The dupplicate should have been that other one.