Bug #60350 Overflow/underflow Error in Queries
Submitted: 4 Mar 2011 22:01 Modified: 28 May 2013 13:12
Reporter: Yuri Sprague Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:4.0.17 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: net 1.0, overflow, underflow

[4 Mar 2011 22:01] Yuri Sprague
Description:
Suddenly, some queries running through an old application written using Microsoft Visual Studio 2002 (.NET 1.0 framework) bomb with a an overflow/underflow error.  When I test the queries in the query browser, they run without problems, so I suspect the problem is with the ODBC interacting with the .NET framework.  It seems to come from the Fill method in the MySQLDataAdapter class (eInfoDesigns.dbProvider.MySqlClient).  We've never experienced this before, though this particular app has been in use for several years; it's only occurred in the past couple weeks and it doesn't happen on everyone's machine. we all run Windows XP SP2 or SP3.

How to repeat:
Not sure, since it seems to be random.
[5 Mar 2011 9:03] Valeriy Kravchuk
What exact version of Connector/ODBC do you use?

You can make a screenshot of the error dialog box and upload it to this bug report.
[5 Apr 2011 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[28 May 2013 13:12] Bogdan Degtyariov
I'm closing this bug because I can not continue without feedback from the reporter. If you have new info, please reopen the report.