Bug #60329 Workbench freezes when trying to connect to non-exist server
Submitted: 4 Mar 2011 4:58 Modified: 15 May 2011 23:50
Reporter: Ronen Baram Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.31 SE OS:Any (WinXP SP3, Mac OS X)
Assigned to: CPU Architecture:Any

[4 Mar 2011 4:58] Ronen Baram
When trying to connect to a non-exist server (I have tried to the SQL Development section) due to an error in the server details, specificity wrong IP, the half-transparent connection status appear and there is no way to cancel until the time-out.
The only to cancel is to kill the task.

How to repeat:
Try to open a connection to server which is shutdown, but has an IP inside the LAN range (eg. for 192.169.0.x, I tried which is no longer there)

Suggested fix:
To add a "Cancel" button.
[4 Mar 2011 5:07] Valeriy Kravchuk
Thank you for the problem report. Verified on Mac OS X also.
[15 May 2011 23:50] Paul DuBois
Noted in 5.2.34 changelog.

Attempting to connect to a nonexistent server put Workbench in
a nonresponsive state.