Bug #60263 Installing Connector/NET on Windows 7 64-bit fails
Submitted: 26 Feb 2011 8:48 Modified: 28 Mar 2011 20:59
Reporter: Derek Tomes Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.3.6 OS:Microsoft Windows (Windows 7 64-bit)
Assigned to: Assigned Account CPU Architecture:Any

[26 Feb 2011 8:48] Derek Tomes
Description:
Installing the MySQL Connector Net 6.3.6 using the mysql.data.msi file fails.

Running the MSI file with verbose logging on shows the following errors:

MSI (s) (48:C4) [21:30:08:711]: Executing op: ActionStart(Name=ManagedDataInstall,Description=Registering data provider in machine.config,)
MSI (s) (48:C4) [21:30:08:714]: Executing op: CustomActionSchedule(Action=ManagedDataInstall,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="\installUtil.exe" /LogToConsole=false /LogFile=  "C:\Program Files (x86)\MySQL\MySQL Connector Net 6.3.6\Assemblies\v2.0\MySql.Data.dll")
MSI (s) (48:14) [21:30:08:731]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI9DAE.tmp, Entrypoint: CAQuietExec
CAQuietExec:  Error 0x80070002: Command failed to execute.
CAQuietExec:  Error 0x80070002: CAQuietExec Failed
CustomAction ManagedDataInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 21:30:08: InstallFinalize. Return value 3.
MSI (s) (48:C4) [21:30:08:773]: User policy value 'DisableRollback' is 0

The documentation suggests:

"21.2.2.1.2. Installing Connector/NET using the Zip packages
If you are having problems running the installer, you can download a Zip file without an installer as an alternative. That file is called mysql-connector-net-version-noinstall.zip. Once downloaded, you can extract the files to a location of your choice."

But I cannot locate the mysql-connector-net-version-noinstall.zip file to download.

How to repeat:
Run the mysql.data.msi file
Select the default options

Suggested fix:
Include a link to the mysql-connector-net-version-noinstall.zip file in the documentation.
[26 Feb 2011 9:04] Valeriy Kravchuk
What version of .NET framework do you use?

This is likely a duplicate of bug #59507.
[26 Feb 2011 22:37] Derek Tomes
G'day Valeriy,

I hope I'm answering this in the right place. I haven't used this bug tracking system before...

> What version of .NET framework do you use?
The following versions of the dot net framework are installed on my computer:
1.0.3705
1.1.4322
2.0.50727
3.0
3.5

I'm also running:
Windows 7 64-bit with all available updates
Visual Studio 2008
Office Office Professional Plus 2010 (64-bit)

> This is likely a duplicate of bug #59507.

Yes, it looks like it. I searched for matching bugs before logging this one. Sorry.
[26 Feb 2011 22:48] Derek Tomes
I have managed to extract the files from the MSI file by creating a folder to unpack them into and running:

msiexec /a "C:\downloads\mysql.data.msi" /qb TARGETDIR="C:\downloads\mysql_temp"

This gives me some folders with various .dll files and samples that I am working through now. I've managed to get the C# Table Editor example to run and connect to a MySQL database.
[26 Feb 2011 22:59] Derek Tomes
I've just tried installing 6.2.4 instead and it worked perfectly. 

Is it possible that 6.3.6 is expecting Visual Studio 2010 and fails because Visual Studio 2008 is installed?
[27 Feb 2011 11:29] Valeriy Kravchuk
I think .NET framework version 4 is expected by .msi of 6.3.6. Please, check.
[28 Feb 2011 2:42] Derek Tomes
My original attempt at installing the MySQL Connector Net 6.3.6 failed.

Probably because VS2010 and the dot net framework v4 were missing from my machine. I was on VS2008 and the latest framework I had was 3.5

So I decided to install the earlier MySQL Connector Net 6.2.4 and it worked correctly.

Not content to have an old version, I've just successfully tried:
1. a side-by-side VS2008 / VS2010 install (which also installs the dot net framework v4
2. un-installing MySQL Connector Net 6.2.4
3. installing MySQL Connector Net 6.3.6

This works correctly, and it even seemed to re-configure both VS2008 and VS2010 during the install (I haven't checked what that means, it was just one of the MSI progress items).

So, I am up and working just fine, but you guys may decided the installer needs fixing.

Thanks,

Derek Tomes
[2 Mar 2011 11:48] Bogdan Degtyariov
Verified in Win7x64 without Framework 4.0.
[28 Mar 2011 20:59] Julio Casal
Duplicate of 59507.