Bug #60053 Cannot run MySQLWorkbench
Submitted: 9 Feb 2011 16:37 Modified: 2 Mar 2011 16:14
Reporter: Richard Morris Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Workbench Severity:S1 (Critical)
Version: CE OS:Windows (XP Pro sp3)
Assigned to: CPU Architecture:Any

[9 Feb 2011 16:37] Richard Morris
When I execute through gui or command line I see the logo screen then nothing;  On the command line here is waht is returned;

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Program Files\MySQL\MySQL Workbench 5.2 CE>
C:\Program Files\MySQL\MySQL Workbench 5.2 CE>MySQLWorkbench

C:\Program Files\MySQL\MySQL Workbench 5.2 CE>
Unhandled Exception: System.InvalidOperationException: Nullable object must have
 a value.
   at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resour
   at ScintillaNet.Configuration.Configuration.readLexerKeywords(XmlReader reade
   at ScintillaNet.Configuration.Configuration.readLexer(XmlReader reader)
   at ScintillaNet.Configuration.Configuration.readLanguage(XmlReader reader)
   at ScintillaNet.Configuration.Configuration.Load(XmlReader reader)
   at ScintillaNet.Configuration.Configuration.Load(Stream inStream, Boolean use
   at ScintillaNet.Configuration.Configuration..ctor(Stream inStream, String lan
guage, Boolean useXmlReader)
   at ScintillaNet.Configuration.ConfigurationManager.Configure()
   at ScintillaNet.Configuration.ConfigurationManager.set_Language(String value)

   at setup_editor(Scintilla scintilla, Boolean use_tabs, Int32 indentation, Str
ing language)
   at MySQL.Forms.CodeEditorImpl.set_language(CodeEditor* self, SyntaxHighlighte
rLanguage language)
   at MySQL.MCallback2<void\,mforms::CodeEditor \*\,enum mforms::SyntaxHighlight
erLanguage>.cpp_callback(CodeEditor* a1, SyntaxHighlighterLanguage a2)
   at wb.WBContextUI.init(WBContextUI* , WBFrontendCallbacks* , WBOptions* )
   at MySQL.Workbench.WbContext.init(WbFrontendCallbacks callbacks, WbOptions op
   at MySQL.GUI.Workbench.Program.Main(String[] Args)

How to repeat:
I just try to execute MySQLWorkbench.exe
[9 Feb 2011 17:14] Richard Morris
I have tried -swrendering still see the same result.  I saw in a closed non solved thread to try the non-install zip.  I unzipped that and ran the MySQLWorkbench  there saw the same issue
[27 Feb 2011 12:12] Valeriy Kravchuk
What exact video card do you have?
[28 Feb 2011 16:24] Richard Morris
ot is an IBM Thinkpad t23  (laptop)  I believe it is Nolia 446Xpro on Mobile Intel(R) 945GM express chip set family
[28 Feb 2011 16:25] Richard Morris
I meant Nokia not Nolia
[28 Feb 2011 16:38] Richard Morris
The Nokia 446Xpro is the monitor  The 945gm express chip set family is the display adapter on the laptop.
[28 Feb 2011 17:00] Richard Morris
Looking closer in the system info looks like the laptop is a Lenovo Thinkpad T60
[1 Mar 2011 8:30] Johannes Taxacher
Hi Richard,
can you add the output of your workbench's "help"->"System info" command?
thanks in advance
[1 Mar 2011 13:38] Richard Morris
Is there a command line option that gives you that?  Only the splash screen appears,  I do not get into the program.
[1 Mar 2011 17:04] Richard Morris
I cannot get into the 5.2 version, but I did find a 5.1 workbench and installed that and the prgram came up here is teh system info from that;

MySQL Workbench OSS for Windows version 5.1.18
Cairo Version: 1.8.6
Rendering Mode: GDI requested (create a diagram to confirm)
OpenGL Driver Version: Not Detected
OS: Windows XP
CPU: 2x Genuine Intel(R) CPU           T2500  @ 2.00GHz, 1.0 GB RAM
Video adapter info:
Adapter type: Mobile Intel(R) 945 Express Chipset Family
Chip Type: Intel(R) GMA 950
BIOS String: Intel Video BIOS
Video Memory: 131072 KB

In the 5.1 version I cannot add or modify any tables i get the following error;

Cannot load selected plugin (.\db.mysql.editors.wbp.fe.dll::DbMysqlTableEditor)
Exception has been thrown by the target of an invocation.
(Nullable object must have a value).

I am not sure if that will help you or not.
[1 Mar 2011 17:43] Richard Morris
I think I figured it out.   I found this article https://connect.microsoft.com/VisualStudio/feedback/details/253265/int32-parse-fails-to-co...

in MS  and I set the value to ""  and I can now enter 5.2,   It also fixed the 5.1 error
[2 Mar 2011 16:14] Valeriy Kravchuk
So, this was .Net-related problem and not a result of any bug in MySQL Workbench code.
[29 Mar 2014 17:19] Roderick II Queral

Problem signature:
  Problem Event Name:	BEX
  Application Name:	MySQLWorkbench.exe
  Application Version:
  Application Timestamp:	35215a95
  Fault Module Name:	StackHash_b2ac
  Fault Module Version:
  Fault Module Timestamp:	00000000
  Exception Offset:	77f2d6f1
  Exception Code:	c0000005
  Exception Data:	00000008
  OS Version:	6.1.7601.
  Locale ID:	1033
  Additional Information 1:	b2ac
  Additional Information 2:	b2ac75544fc168a3ae4985c13e2801ec
  Additional Information 3:	26c0
  Additional Information 4:	26c0557230f90c001ff0a10db58149fa