Bug #59967 Error when creating a new server instance using MySQL Workbench
Submitted: 5 Feb 2011 20:32 Modified: 6 Feb 2011 22:44
Reporter: Joe Zhu Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.31. CE OS:Microsoft Windows (XP with sp3)
Assigned to: CPU Architecture:Any

[5 Feb 2011 20:32] Joe Zhu
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at std.basic_string<char,std::char_traits<char>,std::allocator<char> >.c_str(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* )
   at MySQL.?A0x4861a96a.CppStringToNative(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* str)
   at MySQL.Forms.TextEntryImpl.set_text(TextEntry* self, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* text)
   at MySQL.MCallback2<void\,mforms::TextEntry \*\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&>.cpp_callback(TextEntry* a1, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a2)
   at sigc.internal.signal_emit0<void,sigc::nil>.emit(signal_impl* impl)
   at sigc.signal0<void,sigc::nil>.emit(signal0<void\,sigc::nil>* )
   at mforms.Wizard.next_clicked(Wizard* )
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
My System:
MySQL server version is 5.1.54-community
MySQL server architecture is ia32
MySQL server OS is Win32

Just go to Create New Server Instance, on the Testing Database Connection screen click Next, error popup says "Attempted to read or write protected memory. This is often an indication that other memory is corrupt.".
[6 Feb 2011 9:09] Valeriy Kravchuk
Do you have a Windows service create for this your MySQL server?
[6 Feb 2011 19:34] Joe Zhu
Probably MySQL was not running as a Windows service on my machine, but connection testing from Workbench was successful. Anyway, I later used the installer to reinstall MySQL (I previously used the zip file), and since then I have been able to create a server instance from Workbench without any trouble.
[6 Feb 2011 22:45] MySQL Verification Team
Thank you for the feedback.