Bug #59921 Workbench can't add new user
Submitted: 3 Feb 2011 15:31 Modified: 3 Feb 2011 16:06
Reporter: Jiri Lexa Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.31 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[3 Feb 2011 15:31] Jiri Lexa
Description:
Using workbench 5.2.31 CE, MySQL Server 5.5.8 64bit,
Windows 7 Ultimate 64bit

when adding new account, it throws:
Unhandled exception: Error adding account newuser@%: 

See also the log below.

LOG:
WMIShell: Set filters for local windows cli

ctrl_be: Query Error Error executing 'Field 'authentication_string' doesn't have a default value'

INSERT INTO mysql.user (User, Host, Password, Select_priv, Insert_priv, Update_priv, Delete_priv, Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv, File_priv, Grant_priv, References_priv, Index_priv, Alter_priv, Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv, Execute_priv, Repl_slave_priv, Repl_client_priv, Create_view_priv, Show_view_priv, Create_routine_priv, Alter_routine_priv, Create_user_priv, Event_priv, Trigger_priv, Create_tablespace_priv, max_questions, max_updates, max_connections, max_user_connections, ssl_cipher, x509_issuer, x509_subject) VALUES ('newuser', '%', PASSWORD('a'), 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 'N', 0, 0, 0, 0, '', '', '').

SQL Error: 1364

Traceback (most recent call last):

  File "C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\modules\wb_admin_security.py", line 628, in commit

    self._selected_user.save()

  File "C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\modules\wb_admin_security_be.py", line 656, in save

    raise Exception("Error adding account %s@%s: %s"%(self.username, self.host, e))

Exception: Error adding account newuser@%: 

How to repeat:
Server administration (Local Instance) -> Accounts tab->Add Account
[3 Feb 2011 16:06] Valeriy Kravchuk
This is a duplicate of bug #59000.