Bug #59625 Multiple RBS break the get rseg with mininum trx_t::no code during purge
Submitted: 20 Jan 2011 7:39 Modified: 13 Feb 2012 3:38
Reporter: Sunny Bains Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.5+ OS:Any
Assigned to: Sunny Bains CPU Architecture:Any
Triage: Triaged: D1 (Critical) / R3 (Medium) / E4 (High)

[20 Jan 2011 7:39] Sunny Bains
Description:
When writing an update UNDO log record to disk we only acquire the rseg->mutex in
trx_purge_add_update_undo_to_history(). Simply acquiring the rseg->mutex doesn't
guarantee that the undo log list will be orderd on trx_t::no (serialisation order).

How to repeat:
Code inspection while fixing bug# 59291.
[26 Jan 2011 16:19] Mikhail Izioumtchenko
could bug#55283 be a duplicate of this one?
[30 Nov 2012 9:25] Ovais Tariq
Sunny,

As I understand it this bug was discovered while working on 59291. Would this bug have to do anything with the purge lag seen in 59291.
[2 Dec 2012 8:22] Sunny Bains
This bug has got nothing to do with purge lag, at least I can't see how.