Bug #59600 Feature Request: Visual Studio MySQL Project Template (inc. Schema Comparison)
Submitted: 19 Jan 2011 2:45 Modified: 21 Sep 2011 14:26
Reporter: Rami Abughazaleh Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S4 (Feature request)
Version:6.3.6 OS:Microsoft Windows (Windows 7 Ultimate x64)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D5 (Feature request)

[19 Jan 2011 2:45] Rami Abughazaleh
Description:
I would like to request the ability to create a new "MySQL Server Database Project" in Visual Studio 2010.

I expect its behavior to be very similar to the "SQL Server 2008 Database Project" for example.

Here are two main features I would like to see
1. The ability to compare and synchronize the schema between projects and existing databases.  (This is similar to the "Data > Schema Compare > New Schema Comparison" already built into Visual Studio Premium and Ultimate)
2. instead of a dbo prefix, I expect a mysql prefix to distinguish between sql script files.

Thank you.

How to repeat:
n/a
[19 Jan 2011 8:56] Valeriy Kravchuk
Thank you for the feature request.
[21 Sep 2011 10:33] Christopher Marshall
I'd second this request.  Would be very useful.
[21 Sep 2011 14:26] Reggie Burnett
This feature is on our roadmap.  I can't say yet when this feature might be ready but we are keenly aware of this need.  I'm closing this bug and giving you my assurance that this item is already on our internal roadmap.

Thanks for the input.
[25 Mar 2013 9:35] Uma Hoysala
BugĀ #67233 is duplicate of BugĀ #59600
[12 Nov 2015 15:54] Marco Cannon
Is there any update on when this feature will become available? I see it has been over two years since the last comment was made...
[11 May 2016 15:58] Joe Bloggs
Why has this been closed? Is this feature now available for the latest version of Visual Studio?
[14 Dec 2016 19:04] Ashok Kumar Paramasivam
is anyone has any update on this functionality?

Thanks
[28 Aug 14:05] Kumaraswamy Kovuru
Is this available in VS 2017? We need it badly.