Bug #59548 Does this query to execute?
Submitted: 17 Jan 2011 11:35 Modified: 17 Jan 2011 12:31
Reporter: Seungwoo Song Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Query Cache Severity:S1 (Critical)
Version:5.1.54 OS:Linux (Centos)
Assigned to: CPU Architecture:Any

[17 Jan 2011 11:35] Seungwoo Song
Description:
Does this query to execute?

update lecture set total_a = '10' and order = '10' and order = '1291'
and dis_kind = '10' and idx < 6047745 and total_idx <> 0;

I can't understand
Query make all values of 'total_a' colume to '0'

total_a is vachar(5) defult '0'
mysql version is 5.1.54

How to repeat:
If I use repeat, then i can experience same situation.
[17 Jan 2011 11:36] Seungwoo Song
update lecture set total_a = '10' where user_idx = '10' and order = '1291'
and dis_kind = '10' and idx < 6047745 and total_idx <> 0;

this is right query
[17 Jan 2011 11:40] Shane Bester
not a bug. please check how to write an update statement:
http://dev.mysql.com/doc/refman/5.1/en/update.html

e.g. update t1 set a=1,b=2,c=3 etc.
[17 Jan 2011 12:31] Seungwoo Song
I know how to use update query

I think that query has a syntex error
So must say error message
But it work well --;
I can't understand~
if i use that query at ms-sql, then makes error