Bug #59474 Failing assertion: !(col->prtype & 256)
Submitted: 13 Jan 2011 17:28 Modified: 14 Jan 2011 5:50
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.6.2 OS:Any
Assigned to: CPU Architecture:Any

[13 Jan 2011 17:28] Shane Bester
Description:
Version: '5.6.2-m5-valgrind-max-debug'  socket: '/tmp/mysql.sock'  port: 3306  Source distribution
110113 19:15:16  InnoDB: Assertion failure in thread 140709843314448 in file /home/sbester/build/bzr/mysql-trunk/storage/innobase/rem/rem0rec.c line 808
InnoDB: Failing assertion: !(col->prtype & 256)

(gdb) bt
#0  __pthread_kill
#1  in my_write_core (sig=6) at ./mysys/stacktrace.c:423
#2  in handle_segfault (sig=6) at ./sql/mysqld.cc:2511
#3  <signal handler called>
#4  in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#5  in abort () at abort.c:92
#6  in mach_read_from_n_little_endian at ./storage/innobase/include/mach0data.ic:651
#7  in row_mysql_read_blob_ref at ./storage/innobase/row/row0mysql.c:271
#8  in row_mysql_store_col_in_innobase_format at ./storage/innobase/row/row0mysql.c:490
#9  in row_mysql_convert_row_to_innobase at ./storage/innobase/row/row0mysql.c:542
#10 in row_insert_for_mysql at ./storage/innobase/row/row0mysql.c:1182
#11 in ha_innobase::write_row at ./storage/innobase/handler/ha_innodb.cc:5415
#12 in handler::ha_write_row at ./sql/handler.cc:5855
#13 in write_record at ./sql/sql_insert.cc:1509
#14 in mysql_insert at ./sql/sql_insert.cc:928
#15 in mysql_execute_command at ./sql/sql_parse.cc:2845
#16 in mysql_parse  at ./sql/sql_parse.cc:5550
#17 in dispatch_command  at ./sql/sql_parse.cc:1078
#18 in do_command at ./sql/sql_parse.cc:815
#19 in do_handle_one_connection at ./sql/sql_connect.cc:748
#20 in handle_one_connection at ./sql/sql_connect.cc:684
#21 in start_thread  at pthread_create.c:301
#22 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

How to repeat:
will provide testcase later.
[14 Jan 2011 5:50] Shane Bester
duplicate of bug #59483