Bug #59455 Innodb Deadlock is not reported to error log
Submitted: 12 Jan 2011 18:21 Modified: 12 Jan 2011 18:53
Reporter: Peter Ertel Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Logging Severity:S2 (Serious)
Version:5.1.46 OS:Any
Assigned to:

[12 Jan 2011 18:21] Peter Ertel
Description:
Deadlocks aren't printed into the error log although log_warnings is set to 1.

How to repeat:
Unsure how to reproduce a deadlock. But if you have it, it is only visible via

mysql> SHOW INNODB STATUS\G

However, it should be in log_error (or syslog), too!

Suggested fix:
Print warnings from an engine into log_error/syslog if log_warnings>=1.
[12 Jan 2011 18:35] Peter Ertel
Looks like a duplicate of Bug #1784 (although I wouldn't consider it a feature request).

I see "Pushed into mysql-trunk 5.6.1": Does that mean the path will NOT be available for 5.1.46?
[12 Jan 2011 18:53] Valerii Kravchuk
This is a duplicate of bug #1784. There target version is set as 5.6, so by default the feature should be added to versions 5.6+. 

5.5 is GA already and thus I doubt that this new logging feature will be backported to it (or any older version). Theoretically it is possible (new features appeared in GA MySQL versions in the past), but only if requested by numerous customers. This is not the case with bug #1784, yet.

And, surely, any fix (or new feature) in 5.1.x can appear only in the new release of 5.1, that is, in 5.1.55 or later version. There is almost no way to have any new fix/feature added by MySQL/Oracle to 5.1.46 released long time ago (there are procedures to get that for customers, again, but what they get would be a custom build based on 5.1.46 that is not distributed).