Bug #59372 Cannot select multiple columns in 'Columns' tab of diagram editor
Submitted: 8 Jan 2011 21:29 Modified: 6 Dec 2012 18:59
Reporter: Ben Weller Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.31 rev 7115 OS:MacOS (10.6.4)
Assigned to: CPU Architecture:Any
Tags: interface, mac, osx, UI, workbench

[8 Jan 2011 21:29] Ben Weller
I cannot select more that 1 column within the Table Editor > Columns tab.

I tried to use both [shift] and [control] to select multiple, also tried a "drag" style selection, in case that was implemented.

How to repeat:
Edit a table from the EER Diagram view by double clicking the table graphic.
Select the "Columns" tab, attempt to select multiple columns.

Suggested fix:
Enable selection of multiple rows according to the usual Mac OSX UI patterns.
[9 Jan 2011 9:11] Valeriy Kravchuk
Thank you for the problem report.
[12 Jul 2011 2:11] gary smith
This is still an outstanding issue.  My personal opinion is this is bigger than a minor issue, it makes the Edit function almost useless on a Mac.
[9 Oct 2012 12:51] Edward Crichton

I've just encountered the same issue on 5.2.40, Revision 8790 on Mac OS X 10.6.8.

It doesn't stop me from using it, however the route I take will be different. I will have to create a new table and add the columns I want from the table I wanted to delete from, then delete the old table and rename the new one. That would be quicker than deleting 20+ columns individually; I'm refactoring.

Thanks. :-)

Oh, on a refactoring related note, it might be nice to be able to copy or cut and paste columns between tables?
[6 Dec 2012 18:59] Philip Olson
Fixed as of the upcoming MySQL Workbench 5.2.45, and here's the changelog entry:

It is now possible to select multiple columns in the models table editor
by using "Shift", "Control" ("Command" on Mac OS X), a mouse dragging.

Thank you for the bug report.
[6 Dec 2012 19:09] Philip Olson
The changelog entry was updated to reflect the true status of this report. It now reads as:

The ability to select multiple columns in the models table editor did not
function on Mac OS X. It is now possible to use "Shift", "Command", and
mouse dragging.