Bug #59233 Segmentation Fault on Edit Table
Submitted: 30 Dec 2010 16:15 Modified: 30 Dec 2010 19:57
Reporter: Eddie Carle Email Updates:
Status: Can't repeat Impact on me:
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.31 OS:Linux (Gentoo)
Assigned to: CPU Architecture:Any
Tags: edit table segfault segmentation fault

[30 Dec 2010 16:15] Eddie Carle
I cannot edit a table without a segmentation fault occurring. I've read other bugs that are similar but they seem to have it solved by this version.

Note that is runs fine on my notebook computer which is an all Intel computer whereas my desktop is a NVidia/AMD machine. Both systems are running the same software versions around. Not sure if it has anything to do with it.

** And now a few system details a few details **

uname -a
Linux beta 2.6.36-gentoo-r5 #1 SMP Tue Dec 28 11:07:50 MST 2010 x86_64 AMD Phenom(tm) 9850 Quad-Core Processor AuthenticAMD GNU/Linux

gcc -v
Target: x86_64-pc-linux-gnu
Configured with: /mnt/tmp/portage/sys-devel/gcc-4.4.4-r2/work/gcc-4.4.4/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.4 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.4 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.4/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.4/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/include/g++-v4 --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec --disable-fixed-point --without-ppl --without-cloog --enable-nls --without-included-gettext --with-system-zlib --disable-werror --enable-secureplt --enable-multilib --enable-libmudflap --disable-libssp --enable-libgomp --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.4.4/python --enable-checking=release --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.4.4-r2 p1.3, pie-0.4.5'
Thread model: posix
gcc version 4.4.4 (Gentoo 4.4.4-r2 p1.3, pie-0.4.5)

nvidia driver version: 260.19.29

How to repeat:
load mysql-workbench
create new model
create new EER diagram
create new table
double click on table/right click and select edit
[30 Dec 2010 16:15] Eddie Carle

Attachment: out (application/octet-stream, text), 71.78 KiB.

[30 Dec 2010 17:03] Alfredo Kojima
Please provide a backtrace from gdb. Gentoo is not supported so we will need your help in debugging this, as it doesn't happen under other distributions.
[30 Dec 2010 17:06] Eddie Carle
Is the backtrace in the file I included of no use?
[30 Dec 2010 17:37] Alfredo Kojima
No. Actually I'm not sure seomthing from gdb would help much either.
This needs to be investigated by someone using gentoo, which none of us do, since it's unsupported.

The only guess I have is that the error about fonts that appears before the trace could be related,
in which case I suggest you unset the Editor font in Preferences or prepend the font name with a ! character to see if it helps.
[30 Dec 2010 17:47] Eddie Carle
Good god man. Prepending the font name with a ! fixed everything. Thanks a million.

For curiosities sake though, why did that fix it?
[30 Dec 2010 19:57] Alfredo Kojima
Crash was happening in scintilla editor and it requires a ! in the beginning of font name if a certain font name syntax is used. Don't know why scintilla was crashing because of that, but glad it fixed it for you.
(btw auto-prepending of ! to font names was added to repository, but is not in release version yet)