Bug #59196 Server Administration Setup Attempted to Read/Write Protected Memory
Submitted: 28 Dec 2010 18:33 Modified: 28 Dec 2010 18:51
Reporter: Allen Boone Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.31 CE OS:Microsoft Windows (7 Professional 64-bit)
Assigned to: CPU Architecture:Any

[28 Dec 2010 18:33] Allen Boone
Description:
When I try to create a New Server Instance, I get an error dialog after clicking next on the Testing Database Connection page (the connection test is successful). The dialog says, "Attempted to read or write protected memory. This is often an indication that other memory is corrupt." Exiting the dialog returns me to the New Server Instance wizard on the page with the heading "Set Windows configuration parameters for this machine." Clicking Next produces the error again.

Here's the stack trace:

Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at std.basic_string<char,std::char_traits<char>,std::allocator<char> >.c_str(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* )
   at MySQL.?A0x4861a96a.CppStringToNative(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* str)
   at MySQL.Forms.TextEntryImpl.set_text(TextEntry* self, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* text)
   at MySQL.MCallback2<void\,mforms::TextEntry \*\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&>.cpp_callback(TextEntry* a1, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a2)
   at sigc.internal.signal_emit0<void,sigc::nil>.emit(signal_impl* impl)
   at sigc.signal0<void,sigc::nil>.emit(signal0<void\,sigc::nil>* )
   at mforms.Wizard.next_clicked(Wizard* )
   at MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Try to create a new server instance and click next after the connection is tested successfully to repeat. Clicking next again in the wizard produces the same error again.
[28 Dec 2010 18:51] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=59118.