Bug #58962 Error 1364 during "Apply security settings",
Submitted: 16 Dec 2010 4:45 Modified: 31 Mar 2014 11:20
Reporter: Kerry Coleman Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:5.5.8 OS:Microsoft Windows (Win7Ult_x64)
Assigned to: CPU Architecture:Any
Tags: "apply security settings", 1364, error, Failure, Instance

[16 Dec 2010 4:45] Kerry Coleman
Description:
I completely removed my 5.1 install, using the method i have used since 5.0 that worked.

This time however on the upgrade to 5.5.8 I get the error in the image!

http://db.tt/sRMKDhW

How to repeat:
Install v5.1.53, use for a few weeks, totally uninstall it, restart, go through system with fine tooth comb and make sure all references/files/regs for MySQL are gone, install latest MySQL, once its finished run the instance wizard to create new instance, upon last step, get error during "apply security settings"

Suggested fix:
ummm... dunno!
[16 Dec 2010 4:49] Kerry Coleman
as a side note, google turned up nothing (since as the only article i found on it says it was added in 5.5.7 IIRC, the FAQ/Library/otherFAQ's for MySQL have turned up NOTHING for the error number and/or the string specified!

(and yes the previous install was completely removed, like i said, I had done this since 5.0.x versions without much issue...
[16 Dec 2010 8:42] Peter Laursen
similar:

http://bugs.mysql.com/bug.php?id=58954
http://bugs.mysql.com/bug.php?id=58965
[16 Dec 2010 18:35] Peter Laursen
The image the Kerry uploaded here also appeared in my report here http://bugs.mysql.com/bug.php?id=58954 (after the wizard tried for 30 seconds to apply 'security settings').
[16 Dec 2010 23:36] Kerry Coleman
Peter, that is interesting!

I get this error no matter what option I check for the firewall in the instance setup wizard, or if i manually add it to the firewall!...

do you experience anything different?
[16 Dec 2010 23:47] Peter Laursen
@Kerry.. 

.. I only tried NOT to apply 'firewall exception'.  I have no clue what would happen if I did apply it or if no /datadir existed in advance.

But I am not able to understand how MySQL/Oracle messed up the Windows installer+config wizard in 5.5.  It used to work like a charm in 5.0 and 5.1 (as long as you did not use 64 bit server).

For me things are OK after killing the config wizard when it fails.  My mysql.user table from teh previous installation has what 'security' I want.  I do not want to waste more time with it (wasted too much already) as I already have a working day of 14-15 hours (7 days per week).
[20 Dec 2010 8:48] Valeriy Kravchuk
Kerry,

Do you allow root to connect from remote machines or create anonymous account? If you do then it is the same problem as Bug #59038.
[21 Jan 2011 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[31 Mar 2014 11:19] Yngve Svendsen
Posted by developer:
 
Thank you for the bug report. It has been quite some time since the report was updated, and we are closing this report now since the original config wizard is no longer the focus of Windows deployment efforts. For recent MySQL Server versions, the config wizard is also no longer available, and the MySQL Installer for Windows is the recommended way to install MySQL Server on Windows.
[31 Mar 2014 11:20] Yngve Svendsen
Closing as per comment above.