Bug #58868 shutdown hang waiting for purge thread to be suspended
Submitted: 10 Dec 2010 14:57 Modified: 6 Apr 2012 18:33
Reporter: Mikhail Izioumtchenko Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.6 OS:Any
Assigned to: Sunny Bains CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[10 Dec 2010 14:57] Mikhail Izioumtchenko
Description:
shutdown may hang with messages like this in the log:

Waiting for purge thread  to be suspended

How to repeat:
see private note

Suggested fix:
see private note
[22 Apr 2011 14:41] Valeriy Kravchuk
Bug #60939 was marked as a duplicate of this one.
[6 Apr 2012 18:33] John Russell
Added to changelog for 5.6.5: 

Shutdown could hang with messages like this in the log:

Waiting for purge thread to be suspended 

fter 1 hour, the shutdown times out and
mysqld quits. This problem is most likely to occur with a high value
for innodb_purge_threads.
[29 Dec 2018 14:14] Jayesh Labade
I am also facing same issue,  Please suggest solution