Bug #588 Multi-table update results in "table is full" error, ver. 4.0.12
Submitted: 4 Jun 2003 13:55 Modified: 5 Jun 2003 5:40
Reporter: Jeremy Sher Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: MyISAM storage engine Severity:S1 (Critical)
Version:4.0.12 OS:Linux (Linux)
Assigned to: CPU Architecture:Any

[4 Jun 2003 13:55] Jeremy Sher
Description:
Multi-table update results in "table is full" error -- not clear how so.  The circumstances listed in the "table is full" explanation in the manual don't seem to be applicable.  Using MyISAM tables, the big one is about 0.85 GB.

I saw in the manual (entry for "table is full" error) that this error happened using multi-table update with a different syntax (someone had used "UPDATE table1 INNER JOIN table2 ..."), and there was a note that this would be fixed in 4.0.13.  Submitting as a bug report because it could be the same error.

How to repeat:
Using fairly large tables (about 3.5 million records, 72 fields) in MySQL 4.0.12 on Linux

UPDATE table1,table2 SET table1.field=table2.field WHERE table1.id=table2.id;

Suggested fix:
Don't know.  Multi-table update is really important -- once kinks are worked out it will be huge.
[5 Jun 2003 5:40] Sinisa Milivojevic
Thank you for your bug report. This issue has been fixed in the latest
development tree for that product. You can find more information about
accessing our development trees at 
    http://www.mysql.com/doc/en/Installing_source_tree.html

Actually, it has been fixed in 4.0.13