Bug #58719 Server does not report ER_SP_FETCH_NO_DATA warning any more
Submitted: 3 Dec 2010 19:05 Modified: 15 Dec 2010 12:13
Reporter: Nirbhay Choubey Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Optimizer Severity:S3 (Non-critical)
Version:mysql-5.5.8 OS:Any
Assigned to: CPU Architecture:Any
Tags: regression

[3 Dec 2010 19:05] Nirbhay Choubey
Description:
mysql-5.5.8 does not report warning ER_SP_FETCH_NO_DATA, while 5.5.7-rc
does.

Please look at the attached testcase.

@@ -16,8 +16,6 @@
 END|
 INSERT INTO test.t1 VALUES(1);
 UPDATE test.t1 SET c1 = 0 WHERE c1 = 1;
-Warnings:
-Error  1329    No data - zero rows fetched, selected, or processed
 DROP TRIGGER test.t1_trig;
 DROP TABLE IF EXISTS test.t1;
 DROP TABLE IF EXISTS test.t2;

How to repeat:
perl mtr --suite=bug
[3 Dec 2010 19:06] Nirbhay Choubey
Testcase for this bug.

Attachment: bug.tar.gz (application/x-gzip, text), 653 bytes.

[15 Dec 2010 12:13] Sveta Smirnova
Thank you for the report.

Closed as "Not a Bug" because Elena's comment.