Bug #5862 mysqld crash on all querys (upgrade from 4.0.17 to 4.0.20 and 4.0.21)
Submitted: 2 Oct 2004 19:29 Modified: 2 Oct 2004 21:07
Reporter: Adul Tanthuvanit Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:4.0.21 OS:Linux (Linux)
Assigned to: CPU Architecture:Any

[2 Oct 2004 19:29] Adul Tanthuvanit
Description:
After I upgrade mysql from 4.0.17 to 4.0.20 and 4.0.21 (gcc and icc) for Linux, MySQL server always crash on every querys. Below is information in error log,

=========================
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=1048576
read_buffer_size=126976
max_used_connections=6
max_connections=100
threads_connected=7
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 26223 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x88647a8
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0xbe3ffae0, backtrace may not be correct.
Stack range sanity check OK, backtrace follows:
0x40043820
New value of fp=0x88647a8 failed sanity check, terminating stack trace!
Please read http://www.mysql.com/doc/en/Using_stack_trace.html and follow instructions on how to resolve the stack trace. Res
olved
stack trace is much more helpful in diagnosing the problem, so please do 
resolve it
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x88750d0 = SELECT cover,artist,album FROM musicnr WHERE id=''
thd->thread_id=3
The manual page at http://www.mysql.com/doc/en/Crashing.html contains
information that should help you find out what is causing the crash.
==================================================

After I run resolve_stack_dump, it produce this value
==================================================
0x40043820 _end + 935984920
==================================================

This is my.cnf
==================================================
[mysqld]
default-character-set = tis620
port            = 3306
#bind-address   = localhost
socket          = /tmp/mysql.sock
skip-locking
skip-external-locking
skip-thread-priority
skip-bdb
log-slow-queries
set-variable    = key_buffer=1M
set-variable    = max_allowed_packet=1M
set-variable    = table_cache=300
set-variable    = sort_buffer_size=128K
set-variable    = read_buffer_size=128K
set-variable    = myisam_sort_buffer_size=256K
set-variable    = thread_cache=15
set-variable    = back_log=20
skip-networking
set-variable    = max_connections=100
set-variable    = wait_timeout=20
set-variable    = interactive_timeout=30
innodb_data_file_path = ibdata1:400M:autoextend
innodb_data_home_dir = /home/innodb/
innodb_log_group_home_dir = /home/innodb/
innodb_log_arch_dir = /home/innodb/
set-variable = innodb_mirrored_log_groups=1
set-variable = innodb_log_files_in_group=2
set-variable = innodb_log_file_size=50M
set-variable = innodb_log_buffer_size=5M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_buffer_pool_size=768M
set-variable = innodb_additional_mem_pool_size=24M
set-variable = innodb_file_io_threads=6
set-variable = innodb_lock_wait_timeout=10

How to repeat:
Actually, I don't know.

Suggested fix:
I think the problem is coming from 'default-character-set'.
[2 Oct 2004 21:07] Miguel Solorzano
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.
[30 Oct 2004 21:25] Adul Tanthuvanit
I found problem, Database Server always crash when access table that have VARCHAR(255) column with Default-Character = tis620.

This error still appear in MySQL-4.1.7.
[30 Oct 2004 22:10] Adul Tanthuvanit
Please ignore previous error, I found problem now.

Server must run in character-set=tis620.

Server will crash when try to access table with key (Primary, Unique, Index) longer than 127 characters.
[30 Oct 2004 22:19] Adul Tanthuvanit
I don't sure about a number of characters, but if I use varchar as key and a lot of cardinality in table, when I try to access this table, mysql is crashed.