Bug #58571 ut_ad assert rec_get_deleted_flag(rec, page_is_comp(page))
Submitted: 29 Nov 2010 22:02 Modified: 18 Sep 2012 10:32
Reporter: Mikhail Izioumtchenko Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.1 plugin, 5.5,5.6 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: Triaged: D1 (Critical)

[29 Nov 2010 22:02] Mikhail Izioumtchenko
early during InnoDB crash recovery:

InnoDB: Failing assertion: rec_get_deleted_flag(rec, page_is_comp(page))
101126  1:52:20 - mysqld got signal 6 ;

How to repeat:
InnoDB's internal stress/recovery testing of mysql-trunk-innodb, see private note.
Reproducibility is very low but there was more than one occurrence.
The assert requires UNIV_DEBUG.
[26 Jan 2012 14:35] Marko Mäkelä
This could be the most likely underlying cause of Bug#61104. The problem is that purge is attempted on a record that has not been marked for deletion.
[26 Jan 2012 14:39] Marko Mäkelä
Another possibility is that an insert is attempted by updating a delete-marked record, but the corresponding record is not delete-marked.
[18 Sep 2012 10:32] Marko Mäkelä
This is a duplicate of Bug#66819 InnoDB change buffering is not entirely crash-safe
[29 Aug 2013 7:19] Marko Mäkelä
This could also be a duplicate of
Bug#69979 columns with unique key gets intermittent duplicate values!