Bug #5838 MyODBC fails to insert in BLOB fields
Submitted: 1 Oct 2004 2:05 Modified: 10 May 2007 1:08
Reporter: Jorge del Conde Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51 OS:Microsoft Windows (Win32)
Assigned to: CPU Architecture:Any

[1 Oct 2004 2:05] Jorge del Conde
Description:
MyODBC doesn't insert values in BLOB/TEXT fields with MS SQL Server's Query Analyzer using Linked servers.

How to repeat:
mysql> explain char_tab;
+-------+--------------+------+-----+---------+-------+
| Field | Type | Null | Key | Default | Extra |
+-------+--------------+------+-----+---------+-------+
| i1 | int(11) | YES | | NULL | |
| v1 | varchar(128) | YES | | NULL | |
+-------+--------------+------+-----+---------+-------+
3 rows in set (0.00 sec)

mysql> explain text_tab;
+-------+-------------+------+-----+---------+-------+
| Field | Type | Null | Key | Default | Extra |
+-------+-------------+------+-----+---------+-------+
| i1 | int(11) | YES | | NULL | |
| v1 | mediumtext | YES | | NULL | |
+-------+-------------+------+-----+---------+-------+

Create a linked MySQL server in SQL Server 2000

Open up Query Analyzer and try to execute:

insert into LServ...char_tab(i1, t1) values (1,'THE GETTYSBURG ADDRESS - TITLE') 
and
insert into LServ...text_tab(i1, t1) values (1,'THE GETTYSBURG ADDRESS - TITLE')

You will notice how inserting into text_tab fails with an error message.
[27 Jan 2007 12:32] Louis Breda van
Hello,

I recently reported a bug "25611" related to a textfield update on a view. Reading this bug report, I must say it sounds almost identical since a field and a blob field is about the same.

Astonishing is just the reporting date !! The fact that is is just serious (IMHO it is blocking). And that the bug seems to be still open !!?????

Sincerely,

Louis
[6 Feb 2007 13:52] Tonci Grgin
Louis, not by a long shot... We are working on this one.
[6 Feb 2007 18:37] Louis Breda van
Tonci,

Good that you are working on this one. I asume that you read my comments on the related bug. So you know I found a workarround for that situation, at least that looked that way.

However, for info, my DB is running with that RS-option, but not for long. After lets say 40.000 updates mysql (5114 64 bit) running under vista rc2 64 bit, suddenly starts eating resources and collaps (tasks ends).

Not sure if vista, mysql or eventualy VB-library causes the problem. I will replace Vista with the official released version soon (I allready ordered).

Sincerely,

Louis
[12 Mar 2007 8:18] Tonci Grgin
Louis, as for Vista problem I think the best way is to open new bug report, if problem persists, after *SP1* (oh yes, there will be one, we can count on that...).
[12 Mar 2007 18:42] Louis Breda van
Tonci,

I agree, if you say windows vista (64), does have some strance effects, not to say bugs. However on the other side, the problem I reported was gone after a mysql update to 5115.

Since yesterday, I have the formal vista 64 release with 5116 and 3.51.14 ODBC connector running. Did not yet test anything appart from the installation. That alone however was troublesome enghough (see another bug report).

Sincerely,

Louis
[10 May 2007 1:08] Jim Winstead
This is a duplicate of Bug #19065, which has more information, so I'm going to close this one even though it was reported first.