Bug #58351 MySQl is dead when it excutes to place a table on a diagram everytime
Submitted: 21 Nov 2010 2:20 Modified: 23 Nov 2010 7:45
Reporter: Eric Kim Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:mysql-workbench-gpl-5.2.30-win32 OS:Windows (windows 7 ultimate)
Assigned to: CPU Architecture:Any
Tags: erd diagram, reverse engineering

[21 Nov 2010 2:20] Eric Kim
I tried to make a diagram from my DB. Workbench got the table from DB and tried to palce the tables on a diagram and then it suddenly died everytime. I tried this on the other computer with the same window OS, it made the same result.
So I tried to do this with my SQL Query instead of DB, but the result was exactly same. 

How to repeat:
try to excute reverse engineering function with the option "place the tables on the diagram" on windows 7. It would produce the same promblem

Suggested fix:
I have no idea.
[21 Nov 2010 17:47] Valeriy Kravchuk
Please, send the results of Help > System Info menu item.

What exact version of server, x.y.z, are you working with? How many tables do you have in the database?
[22 Nov 2010 8:36] Eric Kim
I selected the severity as S3 by mistake and now change it as S1.
I have the MySQL run on the local server for my software which is under development. The SQL Editor of workbench runs on my local desktop as well.

And... It does not matter how many tables I have. I tested various SQL and DB which have 25 tables from 275 tables but the editor died at any case.

This is the system info you requested:

MySQL Workbench CE for Windows version 5.2.29
Data Directory: D:\dev\MySQL Workbench 5.2.29 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is not available on this system, so GDI is used for rendering.
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit
CPU: 2x Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: 
Chip Type: Intel(R) 82945G Express Chipset Family
BIOS String: Intel Video BIOS
Video Memory: 262144 KB
Current user language: 영어(캐나다) --> English(Canada)
[22 Nov 2010 8:46] Eric Kim
There are couple of mistakes on my previous report.
1. typing mistake
"And... It does not matter how many tables I have. I tested various SQL and DB which have 25 tables from 275 tables but the editor died at any case."
"And... It does not matter how many tables I have. I tested various SQL and DB which have tables from 25 to 275 but the editor died at any case."

2. Server Version
I am using Xampp so I give you the info generated by Xampp.

Server: localhost via TCP/IP
Server version: 5.1.41
Protocol version: 10
User: root@localhost
MySQL charset: UTF-8 Unicode (utf8)
Web server

Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
MySQL client version: 5.1.41
PHP extension: mysqli

Version information: 3.2.4
[23 Nov 2010 7:45] Eric Kim
I figured out why it happened and solved the problem however I'm still wondering where this cause belongs to.
The situation happened by conflict between Workbench and other application.
I have no idea who has the responsibility for this conflict.
I'll just give you the info for this conflict.

- System 
  - Provider 
   [ Name]  Application Error 
  - EventID 1000 
   [ Qualifiers]  0 
   Level 2 
   Task 100 
   Keywords 0x80000000000000 
  - TimeCreated 
   [ SystemTime]  2010-11-22T10:01:59.000000000Z 
   EventRecordID 29428 
   Channel Application 
   Computer Eric-PC 

- EventData 
   D:\dev\MySQL Workbench 5.2.29 CE\MySQLWorkbench.exe 
   C:\Program Files\Daum\MiniDic\Ver6.4\libApiHook.dll