Bug #58314 (regression) agent inst. 2.3.1.2039 on OSX shows a wrong default in --help msg
Submitted: 19 Nov 2010 8:11 Modified: 27 Jan 2011 22:27
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S1 (Critical)
Version:2.3.1.2039 OS:Mac OS X
Assigned to: BitRock Merlin CPU Architecture:Any

[19 Nov 2010 8:11] Carsten Segieth
Description:
New with 2.3.1.2039, the shown default for "--servicename" in the OSX help text has changed (win32, gtk, xwin not affected):

 --servicename <servicename>    Service Name
                                Default: mysql.monitor.agent

34c35
<                                 Default: mysql-monitor-agent
---
>                                 Default: mysql.monitor.agent

How to repeat:
compare --help text with saved reference from older build
[24 Nov 2010 15:30] BitRock Merlin
Hi,

This is the correct approach. To install a service on OS X it is necessary to create a property wich follow this name convention. You can check similar plist files in the "/Libraries/LaunchDaemons" or "/Library/Preferences/SystemConfiguration" folders. For instance:

com.apple.Boot.plist
com.adobe.SwitchBoard.plist
com.apple.TimeMachine.plist

The installer creates the "mysql.monitor.agent" service and it writes the "mysql.monitor.agent.plist" file by default. If you want to install a second instance you should specify a different service name, for example "mysql.monitor.agent2". In this case the installer will create the "mysql.monitor.agent2.plist" file.
[24 Nov 2010 18:25] Carsten Segieth
I'm not a MacOSX guru, so if this turns out to be a permanent change we may use this bug for tracking the then needed QA test file changes and the (perhaps) needed doc changes.

Anyway, it was a surprising change to me which really looked to me like a bug and not like a "new feature".
[30 Nov 2010 0:59] Enterprise Tools JIRA Robot
Andy Bang writes: 
In build 2.3.1.2039.
[30 Nov 2010 10:03] Enterprise Tools JIRA Robot
Carsten Segieth writes: 
- new ("correct") value now used in reference file
[27 Jan 2011 22:27] John Russell
Distinguished the default agent name by platform, and also specified /Library/LaunchDaemons as the autostart location for OS X. (The relevant text/option for this second part was only in the 2.2 and 2.3 manuals, not earlier.)