Bug #5797 MySqlCommand Error
Submitted: 29 Sep 2004 9:51 Modified: 13 Oct 2004 17:42
Reporter: [ name withheld ] Email Updates:
Status: Duplicate Impact on me:
Category:Connector / NET Severity:S1 (Critical)
Version:Connector/Net 1.0 beta OS:Microsoft Windows (Windows XP)
Assigned to: Assigned Account CPU Architecture:Any

[29 Sep 2004 9:51] [ name withheld ]
If MySqlCommand is initialized with the constructor which takes an Transaction as well, the Parameters collection is not initialized.

Parameters collection is read-only.

How to repeat:
clone = new MySqlCommand( command.CommandText, ((MySqlConnection)(command.Connection)), ((MySqlTransaction)(command.Transaction)) );


clone.Parameters.Add( cloneParam );
//fails, because clone.Parameters is null
[13 Oct 2004 17:42] Reggie Burnett
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in MySQL.

Additional info:

This is a duplicate of #5613 and has been fixed.  Thanks