Bug #57823 Delete row under right mouse click does nothing (regression?)
Submitted: 28 Oct 2010 19:28 Modified: 29 Oct 2010 3:19
Reporter: Bob Tanner Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.29 OS:Mac OS X (Revision 6756)
Assigned to: CPU Architecture:Any
Tags: delete row

[28 Oct 2010 19:28] Bob Tanner
Description:
Looks like a regression of http://bugs.mysql.com/bug.php?id=51361 or something very similar.

The "Delete Row(s)" is grayed out and I'm unable to delete any rows. 

How to repeat:
SELECT * from table; in SQL Query window.
In the Result Tab, right click a row, Delete Row(s) is grayed out.
[28 Oct 2010 21:14] Alfredo Kojima
The result of a SELECT is not editable, you have to use EDIT table; to be able to edit a resultset, including delete rows.
[12 Jul 2015 19:22] Carlos Taylor
This was closed saying you can't delete rows from a select. However this is not the case. I ran into this problem. I can select x rows from the menu on one, and manually select rows, and right click to delete rows, but on this table I just created, it's grayed out and I don't have the option. This is a problem...