Bug #57775 The variable 'time_in_ms' is being used without being initialized.
Submitted: 27 Oct 2010 15:12 Modified: 1 Nov 2010 23:19
Reporter: Horst Hunger Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:mysql-next-mr-bugfixing OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[27 Oct 2010 15:12] Horst Hunger
Description:
The complete error message at runtime:

Error:Run-Time Check Failure #3 - The variable 'time_in_ms' is being used withou
t being initialized. At d:\mysql\mysql-next-mr-wl4445\storage\innobase\os\os0syn
c.c:658

How to repeat:
run alias.test.

Suggested fix:
Workaround: assigned 1000 as initial value to the varible. Tests run.
[27 Oct 2010 17:36] Shane Bester
caused by http://lists.mysql.com/commits/121090 ?
[28 Oct 2010 3:17] Valeriy Kravchuk
With current mysql-next-mr tree alias test runs successfully:

macbook-pro:mysql-test openxs$ ./mtr alias
Logging: ./mtr  alias
101028  6:16:12 [Warning] Setting lower_case_table_names=2 because file system for /var/folders/dX/dXCzvuSlHX4Op1g-o1jIWk+++TI/-Tmp-/8RbOFJAxYG/ is case insensitive
101028  6:16:12 [Note] Plugin 'FEDERATED' is disabled.
101028  6:16:12 [Note] Plugin 'ndbcluster' is disabled.
MySQL Version 5.6.99
Checking supported features...
 - using ndbcluster when necessary, mysqld supports it
 - SSL connections supported
 - binaries are debug compiled
Collecting tests...
vardir: /Users/openxs/dbs/next-mr/mysql-test/var
Checking leftover processes...
Removing old var directory...
Creating var directory '/Users/openxs/dbs/next-mr/mysql-test/var'...
Installing system database...
Using server port 54199

==============================================================================

TEST                                      RESULT   TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
main.alias                               [ pass ]    754
------------------------------------------------------------
The servers were restarted 0 times
Spent 0.754 of 21 seconds executing testcases

Completed: All 1 tests were successful.

So it looks like recent regression.
[28 Oct 2010 7:54] Horst Hunger
AFIR, you need to compile without debug as debug initializes the variables.
[28 Oct 2010 8:02] Horst Hunger
And you need to use Windows. The above mentioned changeset seems indeed to be responsible, as the initialization of the variable has been taken out.
[1 Nov 2010 23:19] Calvin Sun
The problem was introduced by the fix of bug#57232, and already fixed in all trees, starting from 5.5.

r3198 in mysql-5.5-innodb. No need to doc.