Bug #57745 Copying result set via Ctrl+C has extra tab character
Submitted: 26 Oct 2010 18:25 Modified: 30 Jun 2011 9:27
Reporter: Dimitriy A Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.29 CE OS:Microsoft Windows (XP Pro)
Assigned to: CPU Architecture:Any
Tags: blank column, copy, Ctrl+C, extra column, result, tab
Triage: Needs Triage: D4 (Minor)

[26 Oct 2010 18:25] Dimitriy A
Description:
Copying result set via Ctrl+C has extra tab character at the beginning, resulting in an empty column when pasting from the clipboard into a text document or a spreadsheet.

Here is an example of what the pasted output looks like:
	col1	col2	col3
	col1	col2	col3
	col1	col2	col3
	col1	col2	col3
	col1	col2	col3

Instead the clipboard should contain the following:
col1	col2	col3
col1	col2	col3
col1	col2	col3
col1	col2	col3
col1	col2	col3

How to repeat:
Run a query, then select a row or all rows from the result set and copy using Ctrl+C keyboard shortcut.

Suggested fix:
Do not generate a leading tab character into the clipboard during the copy operation.
[26 Oct 2010 19:10] Miguel Solorzano
Thank you for the bug report.