Bug #57693 mysql server instance configuration wizard freezes
Submitted: 24 Oct 2010 14:26 Modified: 30 Oct 2010 15:25
Reporter: crusader deleters Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Config Wizard Severity:S5 (Performance)
Version:5.1.51 & 5.5.6 OS:Windows (32 bit (86))
Assigned to: CPU Architecture:Any

[24 Oct 2010 14:26] crusader deleters
It freezes right halfway through the checklist after config execution.

/ Prepare Config
/ Write Config File
X Start Service
X Apply Security Settings

How to repeat:
I do not suspect it happens to a lot of people, or this would be fixed.

Run the configuration, configure it. Any way I configure it, it freezes.

I do: 

1: Next, Next, Server Machine & Next, Next, Next, Manual 5 & Next, uncheck enable strict mode & next, Next, Next, Enter in passwords & Next, Execute
2: Standard config, next, (entered pw), execute

I just think it is my MySQL download that is wonky.

Suggested fix:
No Known Idea.
[25 Oct 2010 4:41] Valeriy Kravchuk
What exact version of server, 5.1.x, are you trying to install?
[29 Oct 2010 22:15] crusader deleters
Edited Version
5.1 to
[30 Oct 2010 0:45] crusader deleters
Added 5.5.6 to the version.
5.5.6 does the same exact bug.
[30 Oct 2010 15:25] crusader deleters

Fixed. Do not know what happened, but when I re-ran the configuration wizard, and did all my junk, it successfully setup.
[9 Jun 2011 10:04] rajiv sahu

Still getting that issue. I am using Vista Home Basic 32bit and i tried to install using 5.5.10 and 5.5.13. both gave me the exact same problem.
[9 Jun 2011 10:10] rajiv sahu
Also, after the config wizard hangs,  the os shows a popup saying that mysqld.exe had encountered an unexpected problem and is closed.

The weird thing here is that, i have installed this same version before on the same machine, it worked well then, but now, i must have tried more than 10 times, but no luck.

I saw the post where it was mentioned to update some part of assembly using resource hacker, but when i opened it, the fix was already there. Have you guys been reported this issue recently for vista and for latest build. If yes, could you tell me how to fix the issue or atleast which build to use to avoid this problem.
[9 Jun 2011 10:15] rajiv sahu
Can i do the work of instance config wizard manually. Or any other way to do the same. If yes, could you please post that.